summaryrefslogtreecommitdiff
path: root/gnu/packages/file-systems.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-12-05 19:17:41 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-12-05 19:17:41 +0100
commit9bc0f45df5d6aed217020b1183dca54989844fb0 (patch)
treed927e89949ff7f65b5059bc94273c53fd43d0763 /gnu/packages/file-systems.scm
parent6db3c536e89deb8a204e756f427614925a7d2582 (diff)
parent10554e0a57feeea470127a1d0441957d1776b0bd (diff)
downloadguix-patches-9bc0f45df5d6aed217020b1183dca54989844fb0.tar
guix-patches-9bc0f45df5d6aed217020b1183dca54989844fb0.tar.gz
Merge remote-tracking branch 'origin/master' into core-updates-frozen
Diffstat (limited to 'gnu/packages/file-systems.scm')
-rw-r--r--gnu/packages/file-systems.scm14
1 files changed, 6 insertions, 8 deletions
diff --git a/gnu/packages/file-systems.scm b/gnu/packages/file-systems.scm
index e6716e55bc..306144c37a 100644
--- a/gnu/packages/file-systems.scm
+++ b/gnu/packages/file-systems.scm
@@ -251,14 +251,14 @@ unmaintained---to use the @code{inotify} API instead of the deprecated
(define-public davfs2
(package
(name "davfs2")
- (version "1.6.0")
+ (version "1.6.1")
(source
(origin
(method url-fetch)
(uri (string-append "https://download.savannah.nongnu.org/releases/"
"davfs2/davfs2-" version ".tar.gz"))
(sha256
- (base32 "0l1vnv5lfigciwg17p10zxwhzj4qw2d9kw30prr7g4dxhmb6fsrf"))))
+ (base32 "1h65j2py59b97wbzzjhp4wbkk6351v3hrjscjcfab0p5xi4bjgnf"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags
@@ -277,16 +277,14 @@ unmaintained---to use the @code{inotify} API instead of the deprecated
(substitute* "etc/Makefile.in"
(("(dist_pkgdata_DATA =.*) davfs2.conf secrets(.*)"
_ prefix suffix)
- (string-append prefix suffix)))
- #t))
+ (string-append prefix suffix)))))
(add-after 'unpack 'patch-file-names
(lambda _
;; Don't auto-load the FUSE kernel module. That's up to root.
;; XXX If/when we restore the previous behaviour, make sure not
;; to introduce a security hole when mount.davfs is setuid.
(substitute* "src/kernel_interface.c"
- (("/sbin/modprobe") "/modprobe/disabled"))
- #t))
+ (("/sbin/modprobe") "/modprobe/disabled"))))
(replace 'install
(lambda* (#:key make-flags outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
@@ -561,7 +559,7 @@ from the bcachefs-tools package. It is meant to be used in initrds.")
(define-public exfatprogs
(package
(name "exfatprogs")
- (version "1.1.2")
+ (version "1.1.3")
(source
(origin
(method git-fetch)
@@ -570,7 +568,7 @@ from the bcachefs-tools package. It is meant to be used in initrds.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "19pbybgbfnvjb3n944ihrn1r8ch4dm8dr0d44d6w7p63dcp372xy"))))
+ (base32 "14lgwvbg6jibsdpzpcj484p9q4ixawyjxi9hw23w89c6870gglw9"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags