summaryrefslogtreecommitdiff
path: root/gnu/packages/file-systems.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2021-05-13 16:04:17 +0200
committerMathieu Othacehe <othacehe@gnu.org>2021-05-13 16:24:32 +0200
commit95bc788002882a4893ff9734f713b920899be062 (patch)
tree4a71db34122d1cabd7f33a3daa748eae6b05a786 /gnu/packages/file-systems.scm
parentda01347bf1cf09f8a5ceedfea528c546cd744bfe (diff)
downloadguix-patches-95bc788002882a4893ff9734f713b920899be062.tar
guix-patches-95bc788002882a4893ff9734f713b920899be062.tar.gz
gnu: zfs-auto-snapshot: Use git-fetch.
Do not use an autogenerated tarball. This is notified by "guix lint". * gnu/packages/file-systems.scm (zfs-auto-snapshot)[source]: Use git-fetch method.
Diffstat (limited to 'gnu/packages/file-systems.scm')
-rw-r--r--gnu/packages/file-systems.scm17
1 files changed, 10 insertions, 7 deletions
diff --git a/gnu/packages/file-systems.scm b/gnu/packages/file-systems.scm
index e76f4b3030..5d6f9b4a90 100644
--- a/gnu/packages/file-systems.scm
+++ b/gnu/packages/file-systems.scm
@@ -1147,13 +1147,16 @@ community.")
(name "zfs-auto-snapshot")
(version "1.2.4")
(source
- (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/zfsonlinux/zfs-auto-snapshot/archive/upstream/"
- version ".tar.gz"))
- (sha256
- (base32 "16ry1w43i44xc67gr73x6fa48ninfhqxr498ad4m3kya93vp2zrh"))))
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url
+ (string-append "https://github.com/zfsonlinux/" name))
+ (commit
+ (string-append "upstream/" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0m4xw7h5qlbn5zdf9wb137pcr5l7hyrr7w2dgr16dfm5ay64vvfq"))))
(build-system gnu-build-system)
(inputs
;; Note: if you are inheriting from the above zfs package in order