summaryrefslogtreecommitdiff
path: root/gnu/packages/file-systems.scm
diff options
context:
space:
mode:
authorGábor Boskovits <boskovits@gmail.com>2017-11-04 23:35:05 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-11-05 17:50:48 +0100
commit7c5cc400977df8d394cd0aebd0465f94313a0d91 (patch)
tree4b98b8b4e4ace53b550aadda85ed875bea82a73f /gnu/packages/file-systems.scm
parente55c46b850b639f3546ecd311170584a63476d23 (diff)
downloadguix-patches-7c5cc400977df8d394cd0aebd0465f94313a0d91.tar
guix-patches-7c5cc400977df8d394cd0aebd0465f94313a0d91.tar.gz
gnu: add disorderfs.
* gnu/packages/file-systems.scm (disorderfs): New variable. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
Diffstat (limited to 'gnu/packages/file-systems.scm')
-rw-r--r--gnu/packages/file-systems.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/file-systems.scm b/gnu/packages/file-systems.scm
index b4134dec81..407262c4e7 100644
--- a/gnu/packages/file-systems.scm
+++ b/gnu/packages/file-systems.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017 Gábor Boskovits <boskovits@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -20,8 +21,10 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix download)
+ #:use-module (guix git-download)
#:use-module (guix build-system gnu)
#:use-module (gnu packages)
+ #:use-module (gnu packages attr)
#:use-module (gnu packages documentation)
#:use-module (gnu packages docbook)
#:use-module (gnu packages linux)
@@ -86,3 +89,40 @@ ISO images when you only need to inspect their contents or extract specific
files. Since the HTTP protocol itself has no notion of directories, only a
single file can be mounted.")
(license license:gpl2+)))
+
+(define-public disorderfs
+ (package
+ (name "disorderfs")
+ (version "0.5.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ReproducibleBuilds/disorderfs.git")
+ (commit "0.5.2")))
+ (sha256
+ (base32
+ "1j028dq3d4m64mn9xmfamcnnc7i2drmra4pdmxdmqdsi8p7yj4sv"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("fuse" ,fuse)
+ ("attr" ,attr)))
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (delete 'configure))
+ #:make-flags (let ((out (assoc-ref %outputs "out")))
+ (list (string-append "PREFIX=" out)))
+ #:test-target "test"
+ ;; FIXME: Tests require 'run-parts' which is not in Guix yet.
+ #:tests? #f))
+ (home-page "https://github.com/ReproducibleBuilds/disorderfs")
+ (synopsis "FUSE filesystem that introduces non-determinism")
+ (description
+ "An overlay FUSE filesystem that introduces non-determinism
+into filesystem metadata. For example, it can randomize the order
+in which directory entries are read. This is useful for detecting
+non-determinism in the build process.")
+ (license license:gpl3+)))
+