summaryrefslogtreecommitdiff
path: root/gnu/packages/file-systems.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-11-26 22:32:57 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2021-11-27 00:49:55 +0100
commit5aebbbffac71feb50ce73e2e0dfc03d7d05ab5d7 (patch)
treea0c95e1b4d139f347276ad24da1edb0300293de2 /gnu/packages/file-systems.scm
parent6e34b8f35be96a5965a53ae573902306ded8f779 (diff)
downloadguix-patches-5aebbbffac71feb50ce73e2e0dfc03d7d05ab5d7.tar
guix-patches-5aebbbffac71feb50ce73e2e0dfc03d7d05ab5d7.tar.gz
gnu: davfs2: Update to 1.6.1.
* gnu/packages/file-systems.scm (davfs2): Update to 1.6.1. [arguments]: Don't explicitly return #t from phases.
Diffstat (limited to 'gnu/packages/file-systems.scm')
-rw-r--r--gnu/packages/file-systems.scm10
1 files changed, 4 insertions, 6 deletions
diff --git a/gnu/packages/file-systems.scm b/gnu/packages/file-systems.scm
index 4753d95b2e..71bc692f30 100644
--- a/gnu/packages/file-systems.scm
+++ b/gnu/packages/file-systems.scm
@@ -251,14 +251,14 @@ unmaintained---to use the @code{inotify} API instead of the deprecated
(define-public davfs2
(package
(name "davfs2")
- (version "1.6.0")
+ (version "1.6.1")
(source
(origin
(method url-fetch)
(uri (string-append "https://download.savannah.nongnu.org/releases/"
"davfs2/davfs2-" version ".tar.gz"))
(sha256
- (base32 "0l1vnv5lfigciwg17p10zxwhzj4qw2d9kw30prr7g4dxhmb6fsrf"))))
+ (base32 "1h65j2py59b97wbzzjhp4wbkk6351v3hrjscjcfab0p5xi4bjgnf"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags
@@ -277,16 +277,14 @@ unmaintained---to use the @code{inotify} API instead of the deprecated
(substitute* "etc/Makefile.in"
(("(dist_pkgdata_DATA =.*) davfs2.conf secrets(.*)"
_ prefix suffix)
- (string-append prefix suffix)))
- #t))
+ (string-append prefix suffix)))))
(add-after 'unpack 'patch-file-names
(lambda _
;; Don't auto-load the FUSE kernel module. That's up to root.
;; XXX If/when we restore the previous behaviour, make sure not
;; to introduce a security hole when mount.davfs is setuid.
(substitute* "src/kernel_interface.c"
- (("/sbin/modprobe") "/modprobe/disabled"))
- #t))
+ (("/sbin/modprobe") "/modprobe/disabled"))))
(replace 'install
(lambda* (#:key make-flags outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))