summaryrefslogtreecommitdiff
path: root/gnu/packages/file-systems.scm
diff options
context:
space:
mode:
authorRon Nazarov via Guix-patches via <guix-patches@gnu.org>2021-06-02 13:32:45 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2021-06-02 15:40:03 +0200
commit10343994dc562f68771207bf4da313a7d531d2b3 (patch)
treea971016ae2ea6a8488bc38cd9cfc2d1754e9e226 /gnu/packages/file-systems.scm
parent1bd85824c7a04e8c77bb2ba31c310975664c7a53 (diff)
downloadguix-patches-10343994dc562f68771207bf4da313a7d531d2b3.tar
guix-patches-10343994dc562f68771207bf4da313a7d531d2b3.tar.gz
gnu: Add udftools.
* gnu/packages/file-systems.scm (udftools): New variable. Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr>
Diffstat (limited to 'gnu/packages/file-systems.scm')
-rw-r--r--gnu/packages/file-systems.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/file-systems.scm b/gnu/packages/file-systems.scm
index c64c0df727..4d6dc89fd9 100644
--- a/gnu/packages/file-systems.scm
+++ b/gnu/packages/file-systems.scm
@@ -8,6 +8,7 @@
;;; Copyright © 2020 Morgan Smith <Morgan.J.Smith@outlook.com>
;;; Copyright © 2021 raid5atemyhomework <raid5atemyhomework@protonmail.com>
;;; Copyright © 2021 Stefan Reichör <stefan@xsteve.at>
+;;; Copyright © 2021 Noisytoot <noisytoot@disroot.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1526,3 +1527,35 @@ your put them. TMSU maintains its own database and you simply gain an
additional view, which you can mount where you like, based upon the tags you
set up.")
(license license:gpl3+)))
+
+(define-public udftools
+ (package
+ (name "udftools")
+ (version "2.3")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pali/udftools")
+ (commit version)))
+ (sha256
+ (base32
+ "1nl2s61znyzaap23zhbdg3znj6l6akr313fchn5wwvjzj8k70is9"))
+ (file-name (git-file-name name version))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags
+ (list (string-append "--docdir=" (assoc-ref %outputs "out")
+ "/share/doc/" ,name "-" ,version))))
+ (native-inputs
+ `(("automake" ,automake)
+ ("autoconf" ,autoconf)
+ ("libtool" ,libtool)
+ ("pkg-config" ,pkg-config)))
+ (home-page "https://github.com/pali/udftools")
+ (synopsis "Tools to manage UDF file systems and DVD/CD-R(W) drives")
+ (description "@code{udftools} is a set of programs for reading
+and modifying @acronym{UDF, Universal Disk Format} file systems.
+@acronym{UDF, Universal Disk Format} is a file system mostly used for DVDs
+and other optical media. It supports read-only media (DVD/CD-R)
+and rewritable media that wears out (DVD/CD-RW).")
+ (license license:gpl2+)))