summaryrefslogtreecommitdiff
path: root/gnu/packages/fcitx5.scm
diff options
context:
space:
mode:
authorZhu Zihao <all_but_last@163.com>2022-03-05 22:40:46 +0800
committerLudovic Courtès <ludo@gnu.org>2022-04-04 22:58:02 +0200
commitef3cae59a2bc29b666e1c6b468b286f4cbb4974c (patch)
tree27a0a53f9aacbda3f21fa273d178a611450d1d6b /gnu/packages/fcitx5.scm
parent4df7fe14ff47d8858f5c7fc7036b0bb1cc662a86 (diff)
downloadguix-patches-ef3cae59a2bc29b666e1c6b468b286f4cbb4974c.tar
guix-patches-ef3cae59a2bc29b666e1c6b468b286f4cbb4974c.tar.gz
gnu: gtk: Update to 4.6.1.
* gnu/local.mk (dist_patch_DATA): Remove gtk-introspection-test.patch. * gnu/packages/patches/gtk-introspection-test.patch: Remove. * gnu/packages/gtk.scm (gtk): Update to 4.6.1. [source]: Remove stale patch. [arguments]<phases>: Add 'patch-rst2man' phase, correct the binary name of rst2man to 'rst2man.py' [inputs]: Add libjpeg-turbo, libpng, libtiff. [native-inputs]: Add python-docutils. [propagated-inputs]: Use pango-next. * gnu/packages/fcitx5.scm (fcitx5-gtk)[arguments]: Disable GTK4 build. <configure-flags>: Add "-DENABLE_GTK_IM_MODULE=OFF". <phases>: In phase "patch-install-prefix", Remove GTK4 code. [inputs]: Remove package gtk. [outputs]: Remove output "gtk4". Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/fcitx5.scm')
-rw-r--r--gnu/packages/fcitx5.scm15
1 files changed, 6 insertions, 9 deletions
diff --git a/gnu/packages/fcitx5.scm b/gnu/packages/fcitx5.scm
index 13031d6d3d..59085b8fe9 100644
--- a/gnu/packages/fcitx5.scm
+++ b/gnu/packages/fcitx5.scm
@@ -205,7 +205,8 @@ editors.")
#~(list (string-append "-DGOBJECT_INTROSPECTION_GIRDIR="
#$output "/share/gir-1.0")
(string-append "-DGOBJECT_INTROSPECTION_TYPELIBDIR="
- #$output "/lib/girepository-1.0"))
+ #$output "/lib/girepository-1.0")
+ "-DENABLE_GTK4_IM_MODULE=OFF")
#:phases
#~(modify-phases %standard-phases
(add-before 'configure 'patch-install-prefix
@@ -218,11 +219,10 @@ editors.")
(string-append output "/lib"))))
(let ((gtk2 #$output:gtk2)
- (gtk3 #$output:gtk3)
- (gtk4 #$output:gtk4))
+ (gtk3 #$output:gtk3))
(for-each split-immodule
- '("gtk2" "gtk3" "gtk4")
- (list gtk2 gtk3 gtk4))))))))
+ '("gtk2" "gtk3")
+ (list gtk2 gtk3))))))))
(inputs
(list fcitx5
fmt
@@ -232,12 +232,11 @@ editors.")
gobject-introspection
gtk+-2
gtk+
- gtk
glib))
(native-inputs
(list extra-cmake-modules pkg-config
`(,glib "bin"))) ;for glib-genmarshal
- (outputs '("out" "gtk2" "gtk3" "gtk4"))
+ (outputs '("out" "gtk2" "gtk3"))
(home-page "https://github.com/fcitx/fcitx5-gtk")
(synopsis "GLib-based D-Bus client and GTK IM module for Fcitx 5")
(description "Fcitx5-gtk provides the following functionality in the
@@ -250,8 +249,6 @@ GLib-based D-Bus client of Fcitx5.
IM module for GTK+2 applications.
@item gtk3
IM module for GTK+3 applications.
-@item gtk4
-IM module for GTK4 applications.
@end table")
(license license:lgpl2.1+)))