summaryrefslogtreecommitdiff
path: root/gnu/packages/fcitx5.scm
diff options
context:
space:
mode:
authorZhu Zihao <all_but_last@163.com>2020-12-07 22:29:58 +0800
committer宋文武 <iyzsong@member.fsf.org>2020-12-08 20:31:47 +0800
commitad6cf3d4adddf39fbd8318b96756abd933ff6735 (patch)
tree5baef86c4a2aadf587ab285de386c087398a1cd3 /gnu/packages/fcitx5.scm
parent770fb659a62d8adab9a4ba7b44e2760722703879 (diff)
downloadguix-patches-ad6cf3d4adddf39fbd8318b96756abd933ff6735.tar
guix-patches-ad6cf3d4adddf39fbd8318b96756abd933ff6735.tar.gz
gnu: Add xcb-imdkit.
* gnu/packages/fcitx5.scm: New file. * gnu/local.mk (GNU_SYSTEM_MODULES): Add it. Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
Diffstat (limited to 'gnu/packages/fcitx5.scm')
-rw-r--r--gnu/packages/fcitx5.scm62
1 files changed, 62 insertions, 0 deletions
diff --git a/gnu/packages/fcitx5.scm b/gnu/packages/fcitx5.scm
new file mode 100644
index 0000000000..1c81e35862
--- /dev/null
+++ b/gnu/packages/fcitx5.scm
@@ -0,0 +1,62 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2020 Zhu Zihao <all_but_last@163.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages fcitx5)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix build-system cmake)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (gnu packages datastructures)
+ #:use-module (gnu packages kde-frameworks)
+ #:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages xorg))
+
+(define-public xcb-imdkit
+ (package
+ (name "xcb-imdkit")
+ (version "1.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://download.fcitx-im.org/fcitx5/xcb-imdkit/xcb-imdkit-"
+ version ".tar.xz"))
+ (sha256
+ (base32 "1qgbbp8y8ci7haz99vgbrgpjsbrwwyjianyhdvxcirnbm5bybvmz"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; Remove bundled uthash.
+ (delete-file-recursively "uthash")
+ #t))))
+ (build-system cmake-build-system)
+ (inputs
+ `(("uthash" ,uthash)
+ ("libxcb" ,libxcb)
+ ("xcb-util" ,xcb-util)
+ ("xcb-util-keysyms" ,xcb-util-keysyms)))
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)
+ ("pkg-config" ,pkg-config)))
+ (home-page "https://github.com/fcitx/xcb-imdkit")
+ (synopsis "Input method development support for XCB")
+ (description "Xcb-imdkit is an implementation of xim protocol in XCB,
+comparing with the implementation of IMDkit with Xlib, and xim inside Xlib, it
+has less memory foot print, better performance, and safer on malformed
+client.")
+ (license license:lgpl2.1)))