summaryrefslogtreecommitdiff
path: root/gnu/packages/fcitx5.scm
diff options
context:
space:
mode:
authorZhu Zihao <all_but_last@163.com>2021-01-22 17:56:00 +0800
committerEfraim Flashner <efraim@flashner.co.il>2021-01-28 21:16:05 +0200
commit249ab27306dae69ffb836782e4ec5dc2550f2f6c (patch)
treecf5fe7648e281c26a7ec56535671f28fad6d848d /gnu/packages/fcitx5.scm
parent2db7f8f9ac66c68e8593bec70a7c4aab2e3e9cac (diff)
downloadguix-patches-249ab27306dae69ffb836782e4ec5dc2550f2f6c.tar
guix-patches-249ab27306dae69ffb836782e4ec5dc2550f2f6c.tar.gz
gnu: fcitx5-gtk: Update to 5.0.3.
* gnu/packages/fcitx5.scm(fcitx5-gtk): Update to 5.0.3. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/fcitx5.scm')
-rw-r--r--gnu/packages/fcitx5.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/fcitx5.scm b/gnu/packages/fcitx5.scm
index 14de450f37..982536a949 100644
--- a/gnu/packages/fcitx5.scm
+++ b/gnu/packages/fcitx5.scm
@@ -196,7 +196,7 @@ editors.")
(define-public fcitx5-gtk
(package
(name "fcitx5-gtk")
- (version "5.0.1")
+ (version "5.0.3")
(source
(origin
(method url-fetch)
@@ -204,7 +204,7 @@ editors.")
"/fcitx5-gtk/fcitx5-gtk-"
version ".tar.xz"))
(sha256
- (base32 "0h53liraqc5nz4nyi3ixdfdw3zzkdcsiff7j25acc3gmaa5gyij7"))))
+ (base32 "18bwwj9a5v82c6ssc8560hd8vwykakvg6sfijwdb5jswk9mafvgj"))))
(build-system cmake-build-system)
(arguments
`(#:tests? #f ;No test
@@ -212,7 +212,9 @@ editors.")
(list (string-append "-DGOBJECT_INTROSPECTION_GIRDIR="
%output "/share/gir-1.0")
(string-append "-DGOBJECT_INTROSPECTION_TYPELIBDIR="
- %output "/lib/girepository-1.0"))
+ %output "/lib/girepository-1.0")
+ ;; TODO: Enable it when Guix has GTK4.
+ "-DENABLE_GTK4_IM_MODULE=Off")
#:phases
(modify-phases %standard-phases
(add-before 'configure 'patch-install-prefix