summaryrefslogtreecommitdiff
path: root/gnu/packages/fcitx.scm
diff options
context:
space:
mode:
authorRaghav Gururajan <raghavgururajan@disroot.org>2020-06-02 19:41:00 -0400
committerDanny Milosavljevic <dannym@scratchpost.org>2020-08-18 22:54:06 +0200
commitd3ed745e4704fba1ef74c95363acd9a3f99b88f7 (patch)
tree23ea1739ee0b02487db8be1a270d1d6091dbf812 /gnu/packages/fcitx.scm
parent5c5dfb6d9eaeeac529d00834f17ad1a199bee414 (diff)
downloadguix-patches-d3ed745e4704fba1ef74c95363acd9a3f99b88f7.tar
guix-patches-d3ed745e4704fba1ef74c95363acd9a3f99b88f7.tar.gz
gnu: Add presage.
* gnu/packages/fcitx.scm (presage): New variable. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu/packages/fcitx.scm')
-rw-r--r--gnu/packages/fcitx.scm60
1 files changed, 60 insertions, 0 deletions
diff --git a/gnu/packages/fcitx.scm b/gnu/packages/fcitx.scm
index e699d7d59d..279a9c8186 100644
--- a/gnu/packages/fcitx.scm
+++ b/gnu/packages/fcitx.scm
@@ -22,18 +22,78 @@
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system cmake)
+ #:use-module (guix build-system glib-or-gtk)
+ #:use-module (gnu packages check)
#:use-module (gnu packages documentation)
#:use-module (gnu packages enchant)
#:use-module (gnu packages gettext)
#:use-module (gnu packages glib)
+ #:use-module (gnu packages graphviz)
#:use-module (gnu packages gtk)
#:use-module (gnu packages icu4c)
#:use-module (gnu packages iso-codes)
+ #:use-module (gnu packages man)
+ #:use-module (gnu packages ncurses)
#:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages python)
+ #:use-module (gnu packages sqlite)
#:use-module (gnu packages web)
#:use-module (gnu packages xml)
#:use-module (gnu packages xorg))
+(define-public presage
+ (package
+ (name "presage")
+ (version "0.9.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append "mirror://sourceforge/presage/presage/"
+ version "/presage-" version ".tar.gz"))
+ (sha256
+ (base32 "0rm3b3zaf6bd7hia0lr1wyvi1rrvxkn7hg05r5r1saj0a3ingmay"))))
+ (build-system glib-or-gtk-build-system)
+ (outputs '("out" "doc"))
+ (arguments
+ `(#:configure-flags
+ (list
+ "CFLAGS=-Wno-narrowing"
+ "CXXFLAGS=-Wno-narrowing")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'move-doc
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (doc (assoc-ref outputs "doc")))
+ (mkdir-p (string-append doc "/share/presage"))
+ (rename-file
+ (string-append out "/share/presage/html")
+ (string-append doc "/share/presage/html"))
+ #t))))))
+ (native-inputs
+ `(("dot" ,graphviz)
+ ("doxygen" ,doxygen)
+ ("gettext" ,gettext-minimal)
+ ("glib:bin" ,glib "bin")
+ ("gtk+:bin" ,gtk+ "bin")
+ ("help2man" ,help2man)
+ ("pkg-config" ,pkg-config)
+ ("python-wrapper" ,python-wrapper)))
+ (inputs
+ `(("glib" ,glib)
+ ("gtk+" ,gtk+)
+ ("libx11" ,libx11)
+ ("sqlite" ,sqlite)
+ ("tinyxml" ,tinyxml)))
+ (synopsis "Intelligent Predictive Text Entry System")
+ (description "Presage generates predictions by modelling natural language as
+a combination of redundant information sources. It computes probabilities for
+words which are most likely to be entered next by merging predictions generated
+by the different predictive algorithms.")
+ (home-page "https://presage.sourceforge.io/")
+ (license gpl2+)))
+
(define-public fcitx
(package
(name "fcitx")