summaryrefslogtreecommitdiff
path: root/gnu/packages/fcitx.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-13 17:18:24 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-13 17:48:25 +0100
commit8394619baceb118df92e355377fd543bb1aa501a (patch)
tree504f07c2a9f88596a305b59ef45f941062426a52 /gnu/packages/fcitx.scm
parentaca2defe0172868295941fd9f0e97886f6e9b2d4 (diff)
downloadguix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar
guix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar.gz
gnu: Simplify package inputs.
This commit was obtained by running: ./pre-inst-env guix style without any additional argument.
Diffstat (limited to 'gnu/packages/fcitx.scm')
-rw-r--r--gnu/packages/fcitx.scm11
1 files changed, 3 insertions, 8 deletions
diff --git a/gnu/packages/fcitx.scm b/gnu/packages/fcitx.scm
index c602789b45..53680058c0 100644
--- a/gnu/packages/fcitx.scm
+++ b/gnu/packages/fcitx.scm
@@ -81,14 +81,13 @@
"/lib/qt5/plugins")))
#t)))))
(native-inputs
- `(("extra-cmake-modules" ,extra-cmake-modules)
- ("pkg-config" ,pkg-config)))
+ (list extra-cmake-modules pkg-config))
(inputs
`(("fcitx" ,fcitx)
("libintl" ,intltool)
("libxkbcommon" ,libxkbcommon)))
(propagated-inputs
- `(("qtbase" ,qtbase-5)))
+ (list qtbase-5))
(synopsis "Fcitx Qt5 Input Context")
(description "This package provides a Qt5 frontend for fcitx.")
(home-page "https://github.com/fcitx/fcitx-qt5/")
@@ -139,11 +138,7 @@
("pkg-config" ,pkg-config)
("python-wrapper" ,python-wrapper)))
(inputs
- `(("glib" ,glib)
- ("gtk+" ,gtk+)
- ("libx11" ,libx11)
- ("sqlite" ,sqlite)
- ("tinyxml" ,tinyxml)))
+ (list glib gtk+ libx11 sqlite tinyxml))
(synopsis "Intelligent Predictive Text Entry System")
(description "Presage generates predictions by modelling natural language as
a combination of redundant information sources. It computes probabilities for