summaryrefslogtreecommitdiff
path: root/gnu/packages/esolangs.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-13 17:18:24 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-13 17:48:25 +0100
commit8394619baceb118df92e355377fd543bb1aa501a (patch)
tree504f07c2a9f88596a305b59ef45f941062426a52 /gnu/packages/esolangs.scm
parentaca2defe0172868295941fd9f0e97886f6e9b2d4 (diff)
downloadguix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar
guix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar.gz
gnu: Simplify package inputs.
This commit was obtained by running: ./pre-inst-env guix style without any additional argument.
Diffstat (limited to 'gnu/packages/esolangs.scm')
-rw-r--r--gnu/packages/esolangs.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/esolangs.scm b/gnu/packages/esolangs.scm
index 753221a5f1..d38d0bb75c 100644
--- a/gnu/packages/esolangs.scm
+++ b/gnu/packages/esolangs.scm
@@ -52,7 +52,7 @@
;; The tests are not designed to be run and evaluated automatically.
'(#:tests? #f))
(inputs
- `(("ncurses" ,ncurses)))
+ (list ncurses))
(home-page "https://github.com/VorpalBlade/cfunge")
(synopsis "Fast conforming Befunge93/98/109 interpreter in C")
(description "@command{cfunge} is a fast conforming Befunge93/98/109 interpreter
@@ -75,7 +75,7 @@ identified by unique ID codes).")
(base32 "0syw60b93iajgh91ffchirwwhm2kix2753ibx845kyrhzggmdh2l"))))
(build-system cmake-build-system)
(inputs
- `(("readline" ,readline)))
+ (list readline))
(native-inputs
`(("python-2" ,python-2))) ; for the tests
(synopsis "LOLCODE interpreter written in C")
@@ -122,8 +122,7 @@ whenever possible to the extent that the above points are not compromized.
(add-before 'install 'build
(assoc-ref gnu:%standard-phases 'build)))))
(native-inputs
- `(("bison" ,bison)
- ("flex" ,flex)))
+ (list bison flex))
(home-page "http://shakespearelang.sourceforge.net/")
(synopsis "Write programs like Shakespearean plays")
(description "Shakespeare is a programming language with the design goal