summaryrefslogtreecommitdiff
path: root/gnu/packages/esolangs.scm
diff options
context:
space:
mode:
authorLeo Prikler <leo.prikler@student.tugraz.at>2020-12-16 18:50:00 +0100
committerLeo Prikler <leo.prikler@student.tugraz.at>2020-12-29 13:54:48 +0100
commit142f8713ab647ecb8833dcf9eb98e3bdc62cd44a (patch)
treef9ac803b87857becaccc2f7b83c5e2c5cec1216b /gnu/packages/esolangs.scm
parent219612904c005328d892aaf9737c37a91635db2a (diff)
downloadguix-patches-142f8713ab647ecb8833dcf9eb98e3bdc62cd44a.tar
guix-patches-142f8713ab647ecb8833dcf9eb98e3bdc62cd44a.tar.gz
gnu: Add shakespeare-spl.
* gnu/packages/patches/shakespeare-spl-fix-grammar.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it here. * gnu/packages/esolangs.scm (shakespeare-spl): New variable.
Diffstat (limited to 'gnu/packages/esolangs.scm')
-rw-r--r--gnu/packages/esolangs.scm45
1 files changed, 45 insertions, 0 deletions
diff --git a/gnu/packages/esolangs.scm b/gnu/packages/esolangs.scm
index 3986562d57..676b355e65 100644
--- a/gnu/packages/esolangs.scm
+++ b/gnu/packages/esolangs.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2020 Hendursaga <hendursaga@yahoo.com>
+;;; Copyright © 2020 Leo Prikler <leo.prikler@student.tugraz.at>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -17,8 +18,13 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu packages esolangs)
+ #:use-module (gnu packages)
+ #:use-module (gnu packages bison)
+ #:use-module (gnu packages flex)
#:use-module (gnu packages ncurses)
#:use-module (guix build-system cmake)
+ #:use-module (guix build-system copy)
+ #:use-module (guix build-system gnu)
#:use-module (guix download)
#:use-module (guix git-download)
#:use-module ((guix licenses) #:prefix license:)
@@ -49,3 +55,42 @@
written in C. It supports several @dfn{fingerprints} (opt-in language extensions
identified by unique ID codes).")
(license license:gpl3)))
+
+(define-public shakespeare-spl
+ (package
+ (name "shakespeare-spl")
+ (version "1.2.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/shakespearelang/spl-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1lxpfhv01kcwy4l4xgx7j765g8g0v74jns0cr908nfw55h5fy1hj"))
+ (patches
+ (search-patches
+ "shakespeare-spl-fix-grammar.patch"))))
+ (build-system copy-build-system)
+ (arguments
+ `(#:imported-modules (,@%gnu-build-system-modules
+ (guix build copy-build-system))
+ #:modules ((guix build copy-build-system)
+ ((guix build gnu-build-system) #:prefix gnu:)
+ (guix build utils))
+ #:install-plan '(("spl/bin" "bin")
+ ("spl/lib" "lib")
+ ("spl/include" "include"))
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'install 'build
+ (assoc-ref gnu:%standard-phases 'build)))))
+ (native-inputs
+ `(("bison" ,bison)
+ ("flex" ,flex)))
+ (home-page "http://shakespearelang.sourceforge.net/")
+ (synopsis "Write programs like Shakespearean plays")
+ (description "Shakespeare is a programming language with the design goal
+of making programs read like plays. The characters in the play are variables.
+If you want to assign a character, let's say Juliet, a positive value, you put
+her and another character on the stage and let that character praise Juliet.")
+ (license license:gpl2+)))