summaryrefslogtreecommitdiff
path: root/gnu/packages/esolangs.scm
diff options
context:
space:
mode:
authorHendursaga <hendursaga@yahoo.com>2020-08-15 17:05:57 +0000
committerLeo Famulari <leo@famulari.name>2020-12-15 16:59:01 -0500
commit0510ca15aa395ddd3daf0720b541662671bf14c3 (patch)
tree0c7539e9e5877d09843b697b65d97f35439038b0 /gnu/packages/esolangs.scm
parentcf066b7a4eb1426b17442e0bcb779e7d7ff4e150 (diff)
downloadguix-patches-0510ca15aa395ddd3daf0720b541662671bf14c3.tar
guix-patches-0510ca15aa395ddd3daf0720b541662671bf14c3.tar.gz
gnu: Add cfunge.
* gnu/packages/esolangs.scm: New file. * gnu/local.mk (GNU_SYSTEM_MODULES): Add it. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/esolangs.scm')
-rw-r--r--gnu/packages/esolangs.scm51
1 files changed, 51 insertions, 0 deletions
diff --git a/gnu/packages/esolangs.scm b/gnu/packages/esolangs.scm
new file mode 100644
index 0000000000..3986562d57
--- /dev/null
+++ b/gnu/packages/esolangs.scm
@@ -0,0 +1,51 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2020 Hendursaga <hendursaga@yahoo.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages esolangs)
+ #:use-module (gnu packages ncurses)
+ #:use-module (guix build-system cmake)
+ #:use-module (guix download)
+ #:use-module (guix git-download)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix packages))
+
+(define-public cfunge
+ (package
+ (name "cfunge")
+ (version "0.9.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/VorpalBlade/cfunge")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "18ir0h10vxdb5jb57w5hjbgi8spjxg9x2148agadhhmbhsja02m7"))))
+ (build-system cmake-build-system)
+ (arguments
+ ;; The tests are not designed to be run and evaluated automatically.
+ '(#:tests? #f))
+ (inputs
+ `(("ncurses" ,ncurses)))
+ (home-page "https://github.com/VorpalBlade/cfunge")
+ (synopsis "Fast conforming Befunge93/98/109 interpreter in C")
+ (description "@command{cfunge} is a fast conforming Befunge93/98/109 interpreter
+written in C. It supports several @dfn{fingerprints} (opt-in language extensions
+identified by unique ID codes).")
+ (license license:gpl3)))