summaryrefslogtreecommitdiff
path: root/gnu/packages/erlang.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2020-07-03 16:22:43 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-10-07 22:35:30 +0200
commitc71bc563f2087d81f16ebd186b72f96055c251d4 (patch)
treeea216329559adc7174e20c7b0484b6be9439fb74 /gnu/packages/erlang.scm
parent68d3564497092354d7f9c60d8924291ab549eb3f (diff)
downloadguix-patches-c71bc563f2087d81f16ebd186b72f96055c251d4.tar
guix-patches-c71bc563f2087d81f16ebd186b72f96055c251d4.tar.gz
gnu: Add erlang-jsone.
* gnu/packages/erlang.scm (erlang-jsone): New variable.
Diffstat (limited to 'gnu/packages/erlang.scm')
-rw-r--r--gnu/packages/erlang.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/erlang.scm b/gnu/packages/erlang.scm
index b2ba8b22fe..df822d5466 100644
--- a/gnu/packages/erlang.scm
+++ b/gnu/packages/erlang.scm
@@ -423,6 +423,29 @@ arguments using the GNU getopt syntax.")
specifications.")
(license license:asl2.0)))
+(define-public erlang-jsone
+ (package
+ (name "erlang-jsone")
+ (version "1.6.1")
+ (source
+ (origin
+ (method hexpm-fetch)
+ (uri (hexpm-uri "jsone" version))
+ (sha256
+ (base32 "1wdbj4a736bg2fh4qk7y3h6lsdi84ivvypgbkphzy0mfz7nkc97p"))))
+ (build-system rebar3-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'disable-covertool
+ (lambda _
+ (substitute* "rebar.config"
+ (("\\{project_plugins, \\[covertool\\]\\}\\." _) "")))))))
+ (home-page "https://github.com/sile/jsone/")
+ (synopsis "Erlang JSON Library")
+ (description "An Erlang library for encoding and decoding JSON data.")
+ (license license:expat)))
+
(define-public erlang-parse-trans
(package
(name "erlang-parse-trans")