summaryrefslogtreecommitdiff
path: root/gnu/packages/erlang.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-07-13 12:39:46 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-07-13 12:46:20 +0300
commit956b6b078edbb96c207747e89ae485d8a4268c6b (patch)
treeadfb107298a75feedc561243c7fada4e1e1cafb6 /gnu/packages/erlang.scm
parent11c832a7f4d0202a5a0d3d1b47f3f0f64d6e17c0 (diff)
downloadguix-patches-956b6b078edbb96c207747e89ae485d8a4268c6b.tar
guix-patches-956b6b078edbb96c207747e89ae485d8a4268c6b.tar.gz
gnu: erlang: Remove 'autoconf phase.
* gnu/packages/erlang.scm (erlang)[native-inputs]: Remove autoconf, automake. [arguments]: Remove deprecated 'autoconf phase. Remove unneeded 'patch-configure-shell-script.
Diffstat (limited to 'gnu/packages/erlang.scm')
-rw-r--r--gnu/packages/erlang.scm15
1 files changed, 0 insertions, 15 deletions
diff --git a/gnu/packages/erlang.scm b/gnu/packages/erlang.scm
index 35262b9045..e1ffe76f29 100644
--- a/gnu/packages/erlang.scm
+++ b/gnu/packages/erlang.scm
@@ -31,7 +31,6 @@
#:use-module (guix packages)
#:use-module (guix utils)
#:use-module (gnu packages)
- #:use-module (gnu packages autotools)
#:use-module (gnu packages fontutils)
#:use-module (gnu packages gl)
#:use-module (gnu packages ncurses)
@@ -59,8 +58,6 @@
(build-system gnu-build-system)
(native-inputs
`(("perl" ,perl)
- ("autoconf" ,autoconf)
- ("automake" ,automake)
;; Erlang's documentation is distributed in a separate tarball.
("erlang-manpages"
@@ -178,18 +175,6 @@
(lambda _
(setenv "ERL_TOP" (getcwd))
#t))
- (add-after 'patch-source-env 'autoconf
- (lambda _
- (invoke "./otp_build" "autoconf")
- #t))
- (add-after 'autoconf 'patch-configure-script-shell
- (lambda _
- (substitute* "configure"
- (("cmd_str=\"./configure")
- (string-append "cmd_str=\""
- (which "sh")
- " ./configure")))
- #t))
(add-after 'install 'patch-erl
;; This only works after install.
(lambda* (#:key outputs #:allow-other-keys)