summaryrefslogtreecommitdiff
path: root/gnu/packages/erlang.scm
diff options
context:
space:
mode:
authorPjotr Prins <pjotr.public12@thebird.nl>2017-05-06 10:59:25 +0000
committerLudovic Courtès <ludo@gnu.org>2017-05-06 15:50:56 +0200
commit5c4ea872247e38371ed9f9c3509ce566eee907b1 (patch)
treebefb3cf915219e21230aaaab66f0e2d3cbaa4b08 /gnu/packages/erlang.scm
parenta34242eedc4073435f399a5336f227f175e9577f (diff)
downloadguix-patches-5c4ea872247e38371ed9f9c3509ce566eee907b1.tar
guix-patches-5c4ea872247e38371ed9f9c3509ce566eee907b1.tar.gz
gnu: erlang: Update to 19.3.
* gnu/packages/erlang.scm (erlang): Update to 19.3. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/erlang.scm')
-rw-r--r--gnu/packages/erlang.scm14
1 files changed, 6 insertions, 8 deletions
diff --git a/gnu/packages/erlang.scm b/gnu/packages/erlang.scm
index 39da7e939b..07f117e283 100644
--- a/gnu/packages/erlang.scm
+++ b/gnu/packages/erlang.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016 Steve Sprang <scs@stevesprang.com>
;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
-;;; Copyright © 2016 Pjotr Prins <pjotr.public12@thebird.nl>
+;;; Copyright © 2016, 2017 Pjotr Prins <pjotr.guix@thebird.nl>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -34,8 +34,7 @@
(define-public erlang
(package
(name "erlang")
- ;; When updating, remember to update the hash of erlang-manpages!
- (version "19.0")
+ (version "19.3")
(source (origin
(method url-fetch)
;; The tarball from http://erlang.org/download contains many
@@ -46,7 +45,7 @@
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "1dxyz6x1yfv33fd0xfry2ihylkyfa2d655q1vxvbz8dflyd64yqh"))))
+ "1b47jh549yywyp8fbs8a8j4ydr3zn982navzyqvlms6rg8vwb0pw"))))
(build-system gnu-build-system)
(native-inputs
`(("perl" ,perl)
@@ -61,7 +60,7 @@
version ".tar.gz"))
(sha256
(base32
- "07j0l7ary936hil38xr3hvfw6j74pshkyyi98kc9cassbbcdd8y7"))))))
+ "0p6r3n3y7lbhv38sw8f2vi1xlmc137gyspk9ap086w1nszyjy6gq"))))))
(inputs
`(("ncurses" ,ncurses)
("openssl" ,openssl)
@@ -162,9 +161,8 @@
(zero? (system* "tar" "xvf" manpages))
(rename-file "COPYRIGHT"
(string-append share "/misc/erlang/COPYRIGHT"))
- ;; Delete superfluous files.
- (for-each delete-file '("PR.template"
- "README"))))))))))
+ ;; Delete superfluous file.
+ (delete-file "PR.template")))))))))
(home-page "http://erlang.org/")
(synopsis "The Erlang programming language")
(description