summaryrefslogtreecommitdiff
path: root/gnu/packages/entr.scm
diff options
context:
space:
mode:
authorMatthew Jordan <matthewjordandevops@yandex.com>2016-05-11 09:25:13 -0400
committerLudovic Courtès <ludo@gnu.org>2016-05-11 18:16:11 +0200
commit5d38aa082641ba99ff30e508393f33f6ca4789a1 (patch)
tree81fb74c01a65b758484bab341c4661b122d69715 /gnu/packages/entr.scm
parent75e56aedf0f021df02f98fb3e07de83c6e3fd0e1 (diff)
downloadguix-patches-5d38aa082641ba99ff30e508393f33f6ca4789a1.tar
guix-patches-5d38aa082641ba99ff30e508393f33f6ca4789a1.tar.gz
gnu: Add entr.
* gnu/packages/entr.scm: New file. * gnu/local.mk (GNU_SYSTEM_MODULES): Add it. Co-authored-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/entr.scm')
-rw-r--r--gnu/packages/entr.scm66
1 files changed, 66 insertions, 0 deletions
diff --git a/gnu/packages/entr.scm b/gnu/packages/entr.scm
new file mode 100644
index 0000000000..0e0f875267
--- /dev/null
+++ b/gnu/packages/entr.scm
@@ -0,0 +1,66 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2016 Matthew Jordan <matthewjordandevops@yandex.com>
+;;; Copyright © 2016 Ludovic Courtès <ludo@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages entr)
+ #:use-module (guix licenses)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix build-system gnu))
+
+(define-public entr
+ (package
+ (name "entr")
+ (version "3.5")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://entrproject.org/code/entr-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "05k4jyjna0pr2dalwc1l1dhrcyk6pw7hbss7jl4ykwfadcs5br73"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:test-target "test"
+ #:phases (modify-phases %standard-phases
+ (replace 'configure
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (setenv "CONFIG_SHELL" (which "bash"))
+ (setenv "CC" (which "gcc"))
+ (setenv "DESTDIR" (string-append out "/"))
+ (setenv "PREFIX" "")
+ (setenv "MANPREFIX" "man")
+ (zero? (system* "./configure")))))
+ (add-before 'build 'remove-fhs-file-names
+ (lambda _
+ ;; Use the tools available in $PATH.
+ (substitute* "entr.c"
+ (("/bin/cat") "cat")
+ (("/usr/bin/clear") "clear")))))))
+ (home-page "http://entrproject.org/")
+ (synopsis "Run arbitrary commands when files change")
+ (description
+ "entr is a zero-configuration tool with no external build- or run-time
+dependencies. The interface to entr is not only minimal, it aims to be simple
+enough to create a new category of ad hoc automation. These micro-tests
+reduce keystrokes, but more importantly they emphasize the utility of
+automated checks.")
+
+ ;; Per 'LICENSE', portability code under missing/ is under BSD-2.
+ (license isc)))