summaryrefslogtreecommitdiff
path: root/gnu/packages/enlightenment.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-09-01 15:45:37 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-09-01 15:46:53 +0300
commitf911b27918271a3cb50b516d09e943f14b05e228 (patch)
tree964b0cd46c6c7791fc281cd724bc5d9c437acca0 /gnu/packages/enlightenment.scm
parent04b5fb926289f6e234f26d3c24280f2f6aaaea75 (diff)
downloadguix-patches-f911b27918271a3cb50b516d09e943f14b05e228.tar
guix-patches-f911b27918271a3cb50b516d09e943f14b05e228.tar.gz
gnu: enlightenment: Build with wayland support.
* gnu/packages/enlightenment.scm (enlightenment)[arguments]: Add configure-flag to build with wayland support. [inputs]: Add wayland-protocols, xorg-server-xwayland.
Diffstat (limited to 'gnu/packages/enlightenment.scm')
-rw-r--r--gnu/packages/enlightenment.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/enlightenment.scm b/gnu/packages/enlightenment.scm
index 16e9dcb807..cb920c5ff6 100644
--- a/gnu/packages/enlightenment.scm
+++ b/gnu/packages/enlightenment.scm
@@ -303,6 +303,7 @@ Libraries with some extra bells and whistles.")
(let ((efl (assoc-ref %build-inputs "efl")))
(list "-Dsystemd=false"
"-Dpackagekit=false"
+ "-Dwl=true"
(string-append "-Dedje-cc=" efl "/bin/edje_cc")
(string-append "-Deldbus-codegen=" efl "/bin/eldbus-codegen")
(string-append "-Deet=" efl "/bin/eet")))
@@ -363,8 +364,10 @@ Libraries with some extra bells and whistles.")
("linux-pam" ,linux-pam)
("puleseaudio" ,pulseaudio)
("setxkbmap" ,setxkbmap)
+ ("wayland-protocols" ,wayland-protocols)
("xcb-util-keysyms" ,xcb-util-keysyms)
- ("xkeyboard-config" ,xkeyboard-config)))
+ ("xkeyboard-config" ,xkeyboard-config)
+ ("xorg-server-xwayland" ,xorg-server-xwayland)))
(home-page "https://www.enlightenment.org/about-enlightenment")
(synopsis "Lightweight desktop environment")
(description