summaryrefslogtreecommitdiff
path: root/gnu/packages/enlightenment.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-10-02 15:16:32 +0300
committerEfraim Flashner <efraim@flashner.co.il>2019-10-02 20:59:54 +0300
commitecca80e25c76e5076fa02f498038a169f3bbe65a (patch)
tree6f2b2ea48271fefa08307cf6e1066f9a8e318d69 /gnu/packages/enlightenment.scm
parentdde9d858181c45dbed09a51145da4e66fc559997 (diff)
downloadguix-patches-ecca80e25c76e5076fa02f498038a169f3bbe65a.tar
guix-patches-ecca80e25c76e5076fa02f498038a169f3bbe65a.tar.gz
gnu: efl: Update to 1.23.0.
* gnu/packages/enlightenment.scm (efl): Update to 1.23.0. [outputs]: Remove field. [build-system]: Switch to meson-build-system. [native-inputs]: Add check, gettext-minimal. [inputs]: Remove alsa-lib, ghostscript, libexif, openjpeg-1, printproto, xinput, xpr, xorgproto. Add ibus. Move mesa to here. Move libjpeg, libsndfile, libtiff, libwebp, libx11, lz4, pulseaudio ... [propagated-inputs]: ... to here. Add avahi. [arguments]: Add custom phase to work around dbus path issues. Adjust configure-flags for build-system change.
Diffstat (limited to 'gnu/packages/enlightenment.scm')
-rw-r--r--gnu/packages/enlightenment.scm113
1 files changed, 59 insertions, 54 deletions
diff --git a/gnu/packages/enlightenment.scm b/gnu/packages/enlightenment.scm
index 2ff37d496f..737b70b8a6 100644
--- a/gnu/packages/enlightenment.scm
+++ b/gnu/packages/enlightenment.scm
@@ -29,6 +29,7 @@
#:use-module (guix build-system meson)
#:use-module (guix build-system python)
#:use-module (gnu packages)
+ #:use-module (gnu packages avahi)
#:use-module (gnu packages bash)
#:use-module (gnu packages check)
#:use-module (gnu packages code)
@@ -45,6 +46,7 @@
#:use-module (gnu packages gnome)
#:use-module (gnu packages gstreamer)
#:use-module (gnu packages gtk)
+ #:use-module (gnu packages ibus)
#:use-module (gnu packages image)
#:use-module (gnu packages linux)
#:use-module (gnu packages llvm)
@@ -65,7 +67,7 @@
(define-public efl
(package
(name "efl")
- (version "1.22.5")
+ (version "1.23.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -73,28 +75,22 @@
version ".tar.xz"))
(sha256
(base32
- "1cjk56z0whpzcqwg3xdq23kyp1g83xa67m9dlp7ywmb36bn4ca59"))))
- (outputs '("out" ; 53 MB
- "include")) ; 21 MB
- (build-system gnu-build-system)
+ "1iawq5k1ggas41h3vrwc0y98hf83vr0vh3phfgw22iij3cb2b5nd"))))
+ (build-system meson-build-system)
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ `(("check" ,check)
+ ("gettext" ,gettext-minimal)
+ ("pkg-config" ,pkg-config)))
(inputs
- `(("alsa-lib" ,alsa-lib)
- ("curl" ,curl)
- ("ghostscript" ,ghostscript)
+ `(("curl" ,curl)
("giflib" ,giflib)
("gstreamer" ,gstreamer)
("gst-plugins-base" ,gst-plugins-base)
- ("libexif" ,libexif)
- ("libjpeg" ,libjpeg)
+ ("ibus" ,ibus)
+ ("mesa" ,mesa)
("libraw" ,libraw)
("librsvg" ,librsvg)
- ("libsndfile" ,libsndfile)
("libspectre" ,libspectre)
- ("libtiff" ,libtiff)
- ("libwebp" ,libwebp)
- ("libx11" ,libx11)
("libxau" ,libxau)
("libxcomposite" ,libxcomposite)
("libxcursor" ,libxcursor)
@@ -107,55 +103,56 @@
("libxp" ,libxp)
("libxrandr" ,libxrandr)
("libxrender" ,libxrender)
- ("libxscrnsaver" ,libxscrnsaver)
+ ("libxss" ,libxscrnsaver)
("libxtst" ,libxtst)
- ("lz4" ,lz4)
- ("openjpeg" ,openjpeg-1)
("poppler" ,poppler)
- ("printproto" ,printproto)
- ("pulseaudio" ,pulseaudio)
- ("wayland-protocols" ,wayland-protocols)
- ("xinput" ,xinput)
- ("xpr" ,xpr)
- ("xorgproto" ,xorgproto)))
+ ("wayland-protocols" ,wayland-protocols)))
(propagated-inputs
;; All these inputs are in package config files in section
;; Requires.private.
- `(("bullet" ,bullet) ; ephysics.pc
- ("dbus" ,dbus) ; eldbus.pc, elementary.pc, elocation.pc, ethumb_client.pc
- ("eudev" ,eudev) ; eeze.pc
- ("fontconfig" ,fontconfig) ; evas.pc, evas-cxx.pc
- ("freetype" ,freetype) ; evas.pc, evas-cxx.pc
- ("fribidi" ,fribidi) ; evas.pc, evas-cxx.pc
- ("glib" ,glib) ; ecore.pc, ecore-cxx.pc
- ("harfbuzz" ,harfbuzz) ; evas.pc, evas-cxx.pc
- ("luajit" ,luajit) ; elua.pc, evas.pc, evas-cxx.pc
- ("libinput" ,libinput-minimal) ; elput.pc
- ("libpng" ,libpng) ; evas.pc, evas-cxx.pc
- ("libxkbcommon" ,libxkbcommon) ; ecore-wl2.pc, elementary.pc, elput.pc
- ("mesa" ,mesa) ; ecore-drm2.pc
- ("openssl" ,openssl) ; ecore-con.pc, eet.pc, eet-cxx.pc, emile.pc
- ("util-linux" ,util-linux) ; mount: eeze.pc
- ("wayland" ,wayland) ; ecore-wl2.pc, elementary.pc
- ("zlib" ,zlib))) ; eet.pc, eet-cxx.pc, emile.pc
+ `(("avahi" ,avahi)
+ ("bullet" ,bullet)
+ ("dbus" ,dbus)
+ ("eudev" ,eudev)
+ ("fontconfig" ,fontconfig)
+ ("freetype" ,freetype)
+ ("fribidi" ,fribidi)
+ ("glib" ,glib)
+ ("harfbuzz" ,harfbuzz)
+ ("luajit" ,luajit)
+ ("libinput" ,libinput-minimal)
+ ("libjpeg" ,libjpeg)
+ ("libpng" ,libpng)
+ ("libsndfile" ,libsndfile)
+ ("libtiff" ,libtiff)
+ ("libwebp" ,libwebp)
+ ("libx11" ,libx11)
+ ("libxkbcommon" ,libxkbcommon)
+ ("lz4" ,lz4)
+ ("openssl" ,openssl)
+ ("pulseaudio" ,pulseaudio)
+ ("util-linux" ,util-linux)
+ ("wayland" ,wayland)
+ ("zlib" ,zlib)))
(arguments
- `(#:configure-flags '("--disable-silent-rules"
- "--disable-systemd"
- "--with-profile=release"
- "--enable-liblz4"
- "--enable-xinput22"
- "--enable-image-loader-webp"
- "--enable-multisense"
+ `(#:configure-flags '("-Dsystemd=false"
+ "-Dembedded-lz4=false"
+ "-Devas-loaders-disabler=json"
+ "-Dbuild-examples=false"
+ ;(string-append "-Ddictionaries-hyphen-dir="
+ ; (assoc-ref %build-inputs "hyphen")
+ ; "/share/hyphen")
,@(match (%current-system)
("armhf-linux"
- '("--with-opengl=es" "--with-egl"))
+ '("-opengl=es-egl"))
(_
- '("--with-opengl=full")))
- "--enable-harfbuzz"
+ '("-Dopengl=full")))
;; for wayland
- "--enable-wayland"
- "--enable-elput"
- "--enable-drm")
+ "-Dwl-deprecated=true" ; ecore_wayland
+ "-Ddrm-deprecated=true" ; ecore_drm
+ "-Dwl=true"
+ "-Ddrm=true")
+ #:tests? #f ; Many tests fail due to timeouts and network requests.
#:phases
(modify-phases %standard-phases
;; If we don't hardcode the location of libcurl.so then we
@@ -168,6 +165,14 @@
(("libcurl.so.?" libcurl) ; libcurl.so.[45]
(string-append lib libcurl)))
#t)))
+ (add-after 'unpack 'fix-install-paths
+ (lambda _
+ (substitute* "dbus-services/meson.build"
+ (("install_dir.*")
+ "install_dir: join_paths(dir_data, 'dbus-1', 'services'))\n"))
+ (substitute* "src/tests/elementary/meson.build"
+ (("dir_data") "meson.source_root(), 'test-output'"))
+ #t))
(add-after 'unpack 'set-home-directory
;; FATAL: Cannot create run dir '/homeless-shelter/.run' - errno=2
(lambda _ (setenv "HOME" "/tmp") #t)))))