summaryrefslogtreecommitdiff
path: root/gnu/packages/enlightenment.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-12-28 16:16:19 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-12-28 17:05:41 +0200
commit2d5965979d42c74e7f8a9effa7240027e0b96231 (patch)
tree93ef73af92a90e1c4de89eb4b9a6d2afc23492e0 /gnu/packages/enlightenment.scm
parent73ff9d6e0eedae5c365c784906c55918a2ed7507 (diff)
downloadguix-patches-2d5965979d42c74e7f8a9effa7240027e0b96231.tar
guix-patches-2d5965979d42c74e7f8a9effa7240027e0b96231.tar.gz
gnu: ephoto: Update to 1.6.0.
* gnu/packages/enlightenment.scm (ephoto): Update to 1.6.0. [build-system]: Switch to meson-build-system. [arguments]: Remove trailing #t from phases. [native-inputs]: Remove check.
Diffstat (limited to 'gnu/packages/enlightenment.scm')
-rw-r--r--gnu/packages/enlightenment.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/enlightenment.scm b/gnu/packages/enlightenment.scm
index 7bf7ba73e6..4335197e22 100644
--- a/gnu/packages/enlightenment.scm
+++ b/gnu/packages/enlightenment.scm
@@ -516,23 +516,23 @@ and in creating applications based on the Enlightenment Foundation Library suite
(define-public ephoto
(package
(name "ephoto")
- (version "1.5")
+ (version "1.6.0")
(source
(origin
(method url-fetch)
(uri (string-append "https://download.enlightenment.org/rel/"
"apps/ephoto/ephoto-" version ".tar.xz"))
(sha256
- (base32 "1q7v9abjp9jrs08xc7pqaac64yzax24dk1snjb9rciarzzh3mlzy"))))
- (build-system gnu-build-system)
+ (base32 "1lvhcs4ba8h3z78nyycbww8mj4cscb8k200dcc3cdy8vrvrp7g1n"))))
+ (build-system meson-build-system)
(arguments
'(#:phases
(modify-phases %standard-phases
(add-after 'unpack 'set-home-directory
;; FATAL: Cannot create run dir '/homeless-shelter/.run' - errno=2
- (lambda _ (setenv "HOME" "/tmp") #t)))))
+ (lambda _ (setenv "HOME" "/tmp"))))))
(native-inputs
- (list check pkg-config))
+ (list pkg-config))
(inputs
(list efl))
(home-page "https://smhouston.us/projects/ephoto/")