summaryrefslogtreecommitdiff
path: root/gnu/packages/enlightenment.scm
diff options
context:
space:
mode:
authorTimo Eisenmann <eisenmann@fn.de>2018-10-01 18:10:35 +0200
committerLudovic Courtès <ludo@gnu.org>2018-10-02 14:53:39 +0200
commit1df4abc7dcf03f0655fc2fa26de7a6c91bac8b4e (patch)
tree533469896866d106a0900783a1bd92c6f7299741 /gnu/packages/enlightenment.scm
parentf671c59555749161a5960a4c5c373297b60e4be8 (diff)
downloadguix-patches-1df4abc7dcf03f0655fc2fa26de7a6c91bac8b4e.tar
guix-patches-1df4abc7dcf03f0655fc2fa26de7a6c91bac8b4e.tar.gz
gnu: enlightenment: Fix keyboard switching
* gnu/packages/enlightenment.scm (enlightenment)[inputs]: Add 'setxkbmap' [arguments]: Set absolute file name to 'setxkbmap' Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/enlightenment.scm')
-rw-r--r--gnu/packages/enlightenment.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/enlightenment.scm b/gnu/packages/enlightenment.scm
index c7812e8874..c0335016f8 100644
--- a/gnu/packages/enlightenment.scm
+++ b/gnu/packages/enlightenment.scm
@@ -269,6 +269,7 @@ Libraries with some extra bells and whistles.")
(add-before 'configure 'set-system-actions
(lambda* (#:key inputs #:allow-other-keys)
(let ((xkeyboard (assoc-ref inputs "xkeyboard-config"))
+ (setxkbmap (assoc-ref inputs "setxkbmap"))
(utils (assoc-ref inputs "util-linux"))
(libc (assoc-ref inputs "libc")))
;; We need to patch the path to 'base.lst' to be able
@@ -278,6 +279,9 @@ Libraries with some extra bells and whistles.")
(("/usr/share/X11/xkb/rules/xorg.lst")
(string-append xkeyboard
"/share/X11/xkb/rules/base.lst")))
+ (substitute* "src/bin/e_xkb.c"
+ (("\"setxkbmap \"")
+ (string-append "\"" setxkbmap "/bin/setxkbmap \"")))
(substitute* (list "src/bin/e_intl.c"
"src/modules/conf_intl/e_int_config_intl.c"
"src/modules/wizard/page_010.c")
@@ -305,6 +309,7 @@ Libraries with some extra bells and whistles.")
("libxcb" ,libxcb)
("libxext" ,libxext)
("linux-pam" ,linux-pam)
+ ("setxkbmap" ,setxkbmap)
("xcb-util-keysyms" ,xcb-util-keysyms)
("xkeyboard-config" ,xkeyboard-config)))
(home-page "https://www.enlightenment.org/about-enlightenment")