summaryrefslogtreecommitdiff
path: root/gnu/packages/enlightenment.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-25 15:44:35 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-25 16:14:48 -0500
commit0df12a32bba43a0b559b11fba55f080a17fae9b9 (patch)
tree73e39f548daafcd2fff58aa6232689e7077a12b0 /gnu/packages/enlightenment.scm
parent0702bbe1f765bb20d290e661e41fd79baf01aa4b (diff)
downloadguix-patches-0df12a32bba43a0b559b11fba55f080a17fae9b9.tar
guix-patches-0df12a32bba43a0b559b11fba55f080a17fae9b9.tar.gz
gnu: efl: Only conditionally enable the optional SVG support.
* gnu/packages/enlightenment.scm (efl)[inputs] {librsvg}: Only provide it when the target is x86_64. [configure-flags]: Remove dead code. Conditionally disable the 'rsvg' loader via the 'evas-loaders-disabler' flag.
Diffstat (limited to 'gnu/packages/enlightenment.scm')
-rw-r--r--gnu/packages/enlightenment.scm37
1 files changed, 22 insertions, 15 deletions
diff --git a/gnu/packages/enlightenment.scm b/gnu/packages/enlightenment.scm
index d8ae6ad44b..259c44dc58 100644
--- a/gnu/packages/enlightenment.scm
+++ b/gnu/packages/enlightenment.scm
@@ -92,7 +92,11 @@
("ibus" ,ibus)
("mesa" ,mesa)
("libraw" ,libraw)
- ("librsvg" ,librsvg)
+ ;; Only enable the optional SVG support on x86_64, as this is the only
+ ;; architecture where librsvg can be built.
+ ,@(if (target-x86-64?)
+ `(("librsvg" ,librsvg))
+ '())
("libspectre" ,libspectre)
("libtiff" ,libtiff)
("libxau" ,libxau)
@@ -138,20 +142,23 @@
("wayland" ,wayland)
("zlib" ,zlib)))
(arguments
- `(#:configure-flags '("-Dembedded-lz4=false"
- "-Dbuild-examples=false"
- "-Decore-imf-loaders-disabler=scim"
- "-Dglib=true"
- "-Dmount-path=/run/setuid-programs/mount"
- "-Dunmount-path=/run/setuid-programs/umount"
- ;(string-append "-Ddictionaries-hyphen-dir="
- ; (assoc-ref %build-inputs "hyphen")
- ; "/share/hyphen")
- "-Dnetwork-backend=connman"
- ;; for wayland
- "-Dwl=true"
- "-Ddrm=true")
- #:tests? #f ; Many tests fail due to timeouts and network requests.
+ `(#:configure-flags
+ `("-Dembedded-lz4=false"
+ "-Dbuild-examples=false"
+ "-Decore-imf-loaders-disabler=scim"
+ "-Dglib=true"
+ "-Dmount-path=/run/setuid-programs/mount"
+ "-Dunmount-path=/run/setuid-programs/umount"
+ "-Dnetwork-backend=connman"
+ ;; Add 'rsvg' to the default list (json and avif) of disabled loaders
+ ;; unless librsvg is available.
+ ,,@(if (target-x86-64?)
+ '()
+ (list "-Devas-loaders-disabler=json,avif,rsvg"))
+ ;; For Wayland.
+ "-Dwl=true"
+ "-Ddrm=true")
+ #:tests? #f ; Many tests fail due to timeouts and network requests.
#:phases
(modify-phases %standard-phases
;; If we don't hardcode the location of libcurl.so and others then we