summaryrefslogtreecommitdiff
path: root/gnu/packages/engineering.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-11-25 21:11:00 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-11-25 23:56:28 +0100
commitfc14661c7b23d93d4fd3e2eacbbfc8dbe10807c5 (patch)
tree6c2cf420c9a917554ffd86a752c3b21a00afde76 /gnu/packages/engineering.scm
parent8b928a3931cafddb291152bc259b634ab3ab441b (diff)
downloadguix-patches-fc14661c7b23d93d4fd3e2eacbbfc8dbe10807c5.tar
guix-patches-fc14661c7b23d93d4fd3e2eacbbfc8dbe10807c5.tar.gz
gnu: volk: Fetch from git repository.
* gnu/packages/engineering.scm (volk)[source]: Use GIT-FETCH and GIT-FILE-NAME.
Diffstat (limited to 'gnu/packages/engineering.scm')
-rw-r--r--gnu/packages/engineering.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 6463fb73f1..5a66d0a77c 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -1080,11 +1080,13 @@ the 'showing the effect of'-style of operation.")
(version "2.3.0")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://www.libvolk.org/releases/volk-"
- version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gnuradio/volk")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32 "1pjxz3piwy49njj5y2zk437prwkv9lfs5g48577jj3kcsg766vi3"))))
+ (base32 "1jya1v1z1mq50n5fxhs755vcdjvwiv2iqjmycn2l1bx552vzh6cg"))))
(build-system cmake-build-system)
(arguments
`(#:phases