summaryrefslogtreecommitdiff
path: root/gnu/packages/engineering.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-05-25 22:01:31 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-05-27 03:28:10 +0200
commitecc8cd984e69d33c625df775fb779275c90612a7 (patch)
treea874a9b52a984c99c7011ec1afc050c84ed8c500 /gnu/packages/engineering.scm
parent5507ff8e850bf443965a8aa03385895714ae02d2 (diff)
downloadguix-patches-ecc8cd984e69d33c625df775fb779275c90612a7.tar
guix-patches-ecc8cd984e69d33c625df775fb779275c90612a7.tar.gz
gnu: radare2: Add more inputs.
* gnu/packages/engineering.scm (radare2)[arguments]: Add ‘--with-sysxxhash’ to #:configure-flags. [inputs]: Add libuv. [propagated-inputs]: Add xxhash.
Diffstat (limited to 'gnu/packages/engineering.scm')
-rw-r--r--gnu/packages/engineering.scm14
1 files changed, 12 insertions, 2 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 96526cbbf6..2102f8d295 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -61,6 +61,7 @@
#:use-module (gnu packages commencement)
#:use-module (gnu packages compression)
#:use-module (gnu packages curl)
+ #:use-module (gnu packages digest)
#:use-module (gnu packages documentation)
#:use-module (gnu packages flex)
#:use-module (gnu packages fontutils)
@@ -82,6 +83,7 @@
#:use-module (gnu packages image)
#:use-module (gnu packages image-processing)
#:use-module (gnu packages imagemagick)
+ #:use-module (gnu packages libevent)
#:use-module (gnu packages linux) ;FIXME: for pcb
#:use-module (gnu packages m4)
#:use-module (gnu packages maths)
@@ -1354,17 +1356,25 @@ bindings for Python, Java, OCaml and more.")
(mkdir-p (string-append (assoc-ref outputs "out") "/lib"))
#t)))
#:configure-flags
- (list "--with-sysmagic" "--with-syszip" "--with-syscapstone"
- "--with-openssl" "--with-rpath")
+ (list "--with-openssl"
+ "--with-rpath"
+ "--with-syscapstone"
+ "--with-sysmagic"
+ "--with-syszip"
+ "--with-sysxxhash")
#:make-flags
(list "CC=gcc")))
;; TODO: Add gmp and libzip and make the build system actually find them.
(inputs
`(("capstone" ,capstone)
+ ("libuv" ,libuv)
("openssl" ,openssl)
("zip" ,zip)))
(native-inputs
`(("pkg-config" ,pkg-config)))
+ (propagated-inputs
+ ;; In the Libs: section of r_hash.pc.
+ `(("xxhash" ,xxhash)))
(home-page "https://radare.org/")
(synopsis "Reverse engineering framework")
(description