summaryrefslogtreecommitdiff
path: root/gnu/packages/engineering.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-12-06 10:47:46 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-12-06 11:39:07 +0200
commitc70df3c467f86d684967c883e017d76032935880 (patch)
tree92299abe5a2445756d6ecc459aa4eb2c0eec3f9f /gnu/packages/engineering.scm
parente050ddad0b1d33c1669aff5cae43f107a56527a9 (diff)
downloadguix-patches-c70df3c467f86d684967c883e017d76032935880.tar
guix-patches-c70df3c467f86d684967c883e017d76032935880.tar.gz
gnu: poke: Update to 1.4.
* gnu/packages/engineering.scm (poke): Update to 1.4. [native-inputs]: Remove clisp, perl, python-2, and python-3.
Diffstat (limited to 'gnu/packages/engineering.scm')
-rw-r--r--gnu/packages/engineering.scm11
1 files changed, 3 insertions, 8 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index b5bc416772..9438f4c41f 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -2777,27 +2777,22 @@ GUI.")
(define-public poke
(package
(name "poke")
- (version "1.3")
+ (version "1.4")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/poke/poke-" version
".tar.gz"))
(sha256
- (base32
- "06qgry1pal2vampmbmc1lzlhf1qnjkd8py781r5h020v981n6y5s"))))
+ (base32 "095a0qal1fwnqxnal0xb4mp0n4zy97j3ww1j04ij3jb0jpr4s1ff"))))
(build-system gnu-build-system)
;; The GUI, which we elide, requires tcl and tk.
(native-inputs `(;; Requires bison 3.6+ but we currently only have 3.5.
;; Bison 3.6 will be available in the next core update.
("bison-3.6" ,bison-3.6)
- ("clisp" ,clisp)
("dejagnu" ,dejagnu)
("flex" ,flex)
("libtool" ,libtool)
- ("perl" ,perl)
- ("pkg-config" ,pkg-config)
- ("python-2" ,python-2)
- ("python-3" ,python-3)))
+ ("pkg-config" ,pkg-config)))
;; FIXME: Enable NBD support by adding `libnbd' (currently unpackaged).
(inputs `(("json-c" ,json-c)
("libgc" ,libgc)