summaryrefslogtreecommitdiff
path: root/gnu/packages/engineering.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-05-22 02:00:01 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2022-05-22 02:00:01 +0200
commita170622d200fba766f36ec1dfd78bbbfe69ca287 (patch)
treebe4f8a6e68002645a0274def1d815e3832d7a17f /gnu/packages/engineering.scm
parent47b371b61399c7db89092586ac03e9a41342464b (diff)
downloadguix-patches-a170622d200fba766f36ec1dfd78bbbfe69ca287.tar
guix-patches-a170622d200fba766f36ec1dfd78bbbfe69ca287.tar.gz
gnu: libngspice: Update to 37.
* gnu/packages/engineering.scm (libngspice): Update to 37. [arguments]: Remove old "--with-readline=no" work-around from #:configure-flags.
Diffstat (limited to 'gnu/packages/engineering.scm')
-rw-r--r--gnu/packages/engineering.scm9
1 files changed, 3 insertions, 6 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index d19fde7ca4..dc902ef40f 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -1782,7 +1782,7 @@ high-performance parallel differential evolution (DE) optimization algorithm.")
;; See <https://debbugs.gnu.org/cgi/bugreport.cgi?bug=27344#236>.
(package
(name "libngspice")
- (version "36")
+ (version "37")
(source
(origin
(method url-fetch)
@@ -1793,7 +1793,7 @@ high-performance parallel differential evolution (DE) optimization algorithm.")
"old-releases/" version
"/ngspice-" version ".tar.gz")))
(sha256
- (base32 "133za6m9grpnnlb46sijkda7ky41mrbvfdb60i0m695sxy3q50ag"))))
+ (base32 "1gpcic6b6xk3g4956jcsqljf33kj5g43cahmydq6m8rn39sadvlv"))))
(build-system gnu-build-system)
(arguments
`(;; No tests for libngspice exist.
@@ -1819,10 +1819,7 @@ high-performance parallel differential evolution (DE) optimization algorithm.")
(list "--enable-openmp"
"--enable-ciderlib"
"--enable-xspice"
- "--with-ngshared"
- ;; Readline must be disabled to build KiCad with ngspice 34. See
- ;; https://bugs.archlinux.org/task/70563 for reference.
- "--with-readline=no")))
+ "--with-ngshared")))
(native-inputs
(list bison flex))
(inputs