summaryrefslogtreecommitdiff
path: root/gnu/packages/engineering.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-11-25 22:30:02 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-11-25 23:56:29 +0100
commit8da64e9bf9cabb5cd159b66f697ed5e32de3f1f4 (patch)
tree521a5668d7059d8f23a601c90373378f7d12c69a /gnu/packages/engineering.scm
parent6a18f4c5dc6ee78e0b1f9ba757a3a70e0d9726d5 (diff)
downloadguix-patches-8da64e9bf9cabb5cd159b66f697ed5e32de3f1f4.tar
guix-patches-8da64e9bf9cabb5cd159b66f697ed5e32de3f1f4.tar.gz
gnu: volk: Remove static library.
* gnu/packages/engineering.scm (volk)[arguments]: Add a 'remove-static-libraries phase.
Diffstat (limited to 'gnu/packages/engineering.scm')
-rw-r--r--gnu/packages/engineering.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 99b1545b6d..558541dd5a 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -1092,6 +1092,14 @@ the 'showing the effect of'-style of operation.")
(arguments
`(#:phases
(modify-phases %standard-phases
+ (add-after 'install 'remove-static-libraries
+ ;; Remove libcpu_features.a (and any others that might appear).
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (lib (string-append out "/lib")))
+ (for-each delete-file (find-files lib "\\.a$"
+ #:fail-on-error? #t))
+ #t)))
(add-after 'install 'wrap-pythonpath
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))