summaryrefslogtreecommitdiff
path: root/gnu/packages/engineering.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-09-30 09:48:18 +0200
committerLudovic Courtès <ludo@gnu.org>2019-09-30 09:49:34 +0200
commit8d564b8b81b98fec9aac2f5f2d3cb0d1f2ea1416 (patch)
tree8c1987ed2a75933301e485174f9a872c689d0d6e /gnu/packages/engineering.scm
parent737c83f0ff9977572516c65502bdde92abd18629 (diff)
downloadguix-patches-8d564b8b81b98fec9aac2f5f2d3cb0d1f2ea1416.tar
guix-patches-8d564b8b81b98fec9aac2f5f2d3cb0d1f2ea1416.tar.gz
gnu: xyce: Use Bison 3.0.
Xyce requires Bison 3.0 at the latest. * gnu/packages/bison.scm (bison-3.0): New variable. * gnu/packages/engineering.scm (xyce-serial)[native-inputs]: Use BISON-3.0 instead of BISON.
Diffstat (limited to 'gnu/packages/engineering.scm')
-rw-r--r--gnu/packages/engineering.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index bbd9151995..103cb19e83 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -3,7 +3,7 @@
;;; Copyright © 2015 Federico Beffa <beffa@fbengineering.ch>
;;; Copyright © 2016, 2018 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 David Thompson <davet@gnu.org>
-;;; Copyright © 2016, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2016, 2017, 2018, 2019 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2016, 2017, 2018 Theodoros Foradis <theodoros@foradis.org>
;;; Copyright © 2017 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
@@ -1550,7 +1550,7 @@ unique design feature of Trilinos is its focus on packages.")
(string-append "ARCHDIR="
(assoc-ref %build-inputs "trilinos")))))
(native-inputs
- `(("bison" ,bison)
+ `(("bison" ,bison-3.0) ;'configure' fails with Bison 3.4
("flex" ,flex)
("fortran" ,gfortran)))
(inputs