summaryrefslogtreecommitdiff
path: root/gnu/packages/engineering.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2015-12-26 11:30:43 +0100
committerRicardo Wurmus <rekado@elephly.net>2015-12-30 20:41:33 +0100
commit3d5fd24090331feefbdf4ab4093f848a0fe3188b (patch)
tree0ec474fcf43d82342508b60c031432d17f8428a8 /gnu/packages/engineering.scm
parentb7fa2f9321df57a7154ac9d443d8c51e33f31f2e (diff)
downloadguix-patches-3d5fd24090331feefbdf4ab4093f848a0fe3188b.tar
guix-patches-3d5fd24090331feefbdf4ab4093f848a0fe3188b.tar.gz
gnu: Add Fritzing.
* gnu/packages/engineering.scm (fritzing): New variable.
Diffstat (limited to 'gnu/packages/engineering.scm')
-rw-r--r--gnu/packages/engineering.scm51
1 files changed, 51 insertions, 0 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 554399b049..ba11f528cb 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -376,6 +376,57 @@ multipole-accelerated algorithm.")
multipole-accelerated algorithm.")
(license (license:non-copyleft #f "See induct.c."))))
+(define-public fritzing
+ (package
+ (name "fritzing")
+ (version "0.9.2b")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/fritzing/"
+ "fritzing-app/archive/" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0pvk57z2pxz89pcwwm61lkpvj4w9qxqz8mi0zkpj6pnaljabp7bf"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'configure
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (and (zero? (system* "tar"
+ "-xvf" (assoc-ref inputs "fritzing-parts-db")
+ "-C" "parts"))
+ (zero? (system* "qmake"
+ (string-append "PREFIX="
+ (assoc-ref outputs "out"))
+ "phoenix.pro"))))))))
+ (inputs
+ `(("qt" ,qt)
+ ("boost" ,boost)
+ ("zlib" ,zlib)
+ ("fritzing-parts-db"
+ ,(origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/fritzing/"
+ "fritzing-parts/archive/" version ".tar.gz"))
+ (file-name (string-append "fritzing-parts-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0jqr8yjg7177f3pk1fcns584r0qavwpr280nggsi2ff3pwk5wpsz"))))))
+ (home-page "http://fritzing.org")
+ (synopsis "Electronic circuit design")
+ (description
+ "The Fritzing application is @dfn{Electronic Design Automation} (EDA)
+software with a low entry barrier, suited for the needs of makers and
+hobbyists. It offers a unique real-life \"breadboard\" view, and a parts
+library with many commonly used high-level components. Fritzing makes it very
+easy to communicate about circuits, as well as to turn them into PCB layouts
+ready for production.")
+ ;; Documentation and parts are released under CC-BY-SA 3.0; source code is
+ ;; released under GPLv3+.
+ (license (list license:gpl3+ license:cc-by-sa3.0))))
+
(define-public gerbv
(package
(name "gerbv")