summaryrefslogtreecommitdiff
path: root/gnu/packages/engineering.scm
diff options
context:
space:
mode:
authorSteve Sprang <scs@stevesprang.com>2019-08-23 15:23:00 -0700
committerLudovic Courtès <ludo@gnu.org>2019-08-31 21:04:09 +0200
commit2c0040ae302fa8549161754283b404b9dd22a619 (patch)
tree2c2b0aa52e6e7a5fe9860f010359079fa93b7e60 /gnu/packages/engineering.scm
parent4cb5d2515ca0061f1e2b0b422d54df705ddc4956 (diff)
downloadguix-patches-2c0040ae302fa8549161754283b404b9dd22a619.tar
guix-patches-2c0040ae302fa8549161754283b404b9dd22a619.tar.gz
gnu: Add lib3mf.
* gnu/packages/engineering.scm (lib3mf): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/engineering.scm')
-rw-r--r--gnu/packages/engineering.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index a1f222bed4..54bf5a7b69 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -12,6 +12,7 @@
;;; Copyright © 2018, 2019 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2019 Tim Stahel <swedneck@swedneck.xyz>
;;; Copyright © 2019 Jovany Leandro G.C <bit4bit@riseup.net>
+;;; Copyright © 2019 Steve Sprang <scs@stevesprang.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2109,3 +2110,38 @@ while keeping the user experience at mind. Cutter is created by reverse
engineers for reverse engineers.")
(license (list license:cc-by-sa3.0 ;the "Iconic" icon set
license:gpl3+)))) ;everything else
+
+(define-public lib3mf
+ (package
+ (name "lib3mf")
+ (version "1.8.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference (url "https://github.com/3MFConsortium/lib3mf.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "11wpk6n9ga2p57h1dcrp37w77mii0r7r6mlrgmykf7rvii1rzgqd"))))
+ (build-system cmake-build-system)
+ (native-inputs
+ `(("googletest-source" ,(package-source googletest))))
+ (inputs
+ `(("libuuid" ,util-linux)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'unpack-googletest
+ (lambda* (#:key inputs #:allow-other-keys)
+ (copy-recursively (assoc-ref inputs "googletest-source")
+ "UnitTests/googletest")
+ #t)))))
+ (synopsis "Implementation of the 3D Manufacturing Format (3MF) file standard")
+ (description
+ "Lib3MF is a C++ implementation of the 3D Manufacturing Format (3MF) file
+standard. It offers a way to integrate 3MF reading and writing capabilities, as
+well as conversion and validation tools for input and output data. The
+specification can be downloaded at @url{http://3mf.io/specification/}.")
+ (home-page "https://3mf.io/")
+ (license license:bsd-2)))