summaryrefslogtreecommitdiff
path: root/gnu/packages/engineering.scm
diff options
context:
space:
mode:
authorphodina <phodina@protonmail.com>2021-12-03 21:37:32 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-12-03 21:38:30 +0100
commit269baba919886961979d91670f9f755daa6ce160 (patch)
treecd9c2868ca44ed4e31c36b73b8c60a26c0a1fcf0 /gnu/packages/engineering.scm
parent19528e39bb00cc25a41a134f7af63873fa297b77 (diff)
downloadguix-patches-269baba919886961979d91670f9f755daa6ce160.tar
guix-patches-269baba919886961979d91670f9f755daa6ce160.tar.gz
gnu: Add valeronoi.
* gnu/packages/engineering.scm (valeronoi): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/engineering.scm')
-rw-r--r--gnu/packages/engineering.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 50f265f085..20402151cb 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -25,6 +25,7 @@
;;; Copyright © 2021 Gerd Heber <gerd.heber@gmail.com>
;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2021 Ivan Gankevich <i.gankevich@spbu.ru>
+;;; Copyright © 2021 Petr Hodina <phodina@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -129,6 +130,7 @@
#:use-module (gnu packages xml)
#:use-module (gnu packages xiph)
#:use-module (gnu packages openkinect)
+ #:use-module (gnu packages xdisorg)
#:use-module (gnu packages xorg))
(define-public librecad
@@ -1156,6 +1158,44 @@ educational use. As such, there is an emphasis on capabilities that improve
the 'showing the effect of'-style of operation.")
(license license:gpl2+)))
+(define-public valeronoi
+(package
+ (name "valeronoi")
+ (version "0.1.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/ccoors/Valeronoi")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1zp653bjqsyixa5j1pp9k12iqsl8dz72yyi38asxmcym1wngsjcd"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "./valeronoi-tests")))))))
+ (inputs
+ `(("boost" ,boost)
+ ("cgal" ,cgal)
+ ("gmp" ,gmp)
+ ("libxkbcommon" ,libxkbcommon)
+ ("mpfr" ,mpfr)
+ ("openssl" ,openssl)
+ ("qtbase" ,qtbase-5)
+ ("qtsvg" ,qtsvg)))
+ (home-page "https://github.com/ccoors/Valeronoi")
+ (synopsis "WiFi mapping companion application for Valetudo")
+ (description
+ "Valeronoi (Valetudo + Voronoi) is a companion for Valetudo for generating
+WiFi signal strength maps. It visualizes them using a Voronoi diagram.")
+ (license license:gpl3+)))
+
(define-public volk
(package
(name "volk")