summaryrefslogtreecommitdiff
path: root/gnu/packages/engineering.scm
diff options
context:
space:
mode:
authorMalte Frank Gerdes <malte.f.gerdes@gmail.com>2022-04-07 17:28:35 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2022-04-07 22:32:01 +0200
commit21594c06b1b63b9e7b9a5c95ea5f063c34233eed (patch)
treebb06aa47acbe5c19e9b13bc57cdbee8788e01a5a /gnu/packages/engineering.scm
parent79b50d5d5b465504511d9fbd735e7b3ddb6eb1de (diff)
downloadguix-patches-21594c06b1b63b9e7b9a5c95ea5f063c34233eed.tar
guix-patches-21594c06b1b63b9e7b9a5c95ea5f063c34233eed.tar.gz
gnu: Add libsavitar.
* gnu/packages/engineering.scm (libsavitar): New variable. Co-authored-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages/engineering.scm')
-rw-r--r--gnu/packages/engineering.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 040c2a3ef0..0bf4681ea1 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -3454,3 +3454,41 @@ from Ultimaker.")
(description "LibCharon is a Python file metadata and streaming library. It
belongs to the Cura project from Ultimaker.")
(license license:lgpl3+)))
+
+(define-public libsavitar
+ (package
+ (name "libsavitar")
+ (version "4.13.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Ultimaker/libSavitar")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1cq85x0xizsjwf9nl7v7x4i9vl335mgv2lda3q2c9fcwrndsc3wk"))))
+ (build-system cmake-build-system)
+ (inputs
+ (list python python-sip-4))
+ (arguments
+ `(#:tests? #f ; No test suite.
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'fix-python-sitearch
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((path (string-append (assoc-ref outputs "out")
+ "/lib/python"
+ ,(version-major+minor
+ (package-version python))
+ "/site-packages")))
+ (substitute* "cmake/FindSIP.cmake"
+ (("\\$\\{_process_output\\} Python3_SITEARCH")
+ (string-append path " Python3_SITEARCH"))
+ (("\\$\\{_process_output\\} Python3_SITELIB")
+ (string-append path " Python3_SITELIB")))))))))
+ (home-page "https://github.com/Ultimaker/libSavitar")
+ (synopsis "C++ implementation of 3mf loading with SIP python bindings")
+ (description "LibSavitar is a C++ implementation of 3mf loading with SIP
+python bindings. It belongs to the Cura project from Ultimaker.")
+ (license license:lgpl3+)))