summaryrefslogtreecommitdiff
path: root/gnu/packages/engineering.scm
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2021-12-18 16:53:39 +0000
committerMathieu Othacehe <othacehe@gnu.org>2021-12-23 17:52:17 +0100
commit01477bce71e371ab552286131b9b96671d7b16cf (patch)
tree2d0ed0a30ab44280bd4a9c5be50fb33cd4455994 /gnu/packages/engineering.scm
parent037c2b6d3acdf7f5b68ecb3024ef90bce85922df (diff)
downloadguix-patches-01477bce71e371ab552286131b9b96671d7b16cf.tar
guix-patches-01477bce71e371ab552286131b9b96671d7b16cf.tar.gz
gnu: Add qelectrotech.
* gnu/packages/engineering.scm (qelectrotech): New variable. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/engineering.scm')
-rw-r--r--gnu/packages/engineering.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index e0fe0f354f..4265c4134c 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -97,6 +97,7 @@
#:use-module (gnu packages image)
#:use-module (gnu packages image-processing)
#:use-module (gnu packages imagemagick)
+ #:use-module (gnu packages kde-frameworks)
#:use-module (gnu packages libevent)
#:use-module (gnu packages libusb)
#:use-module (gnu packages linux) ;FIXME: for pcb
@@ -716,6 +717,43 @@ ready for production.")
;; released under GPLv3+.
(license (list license:gpl3+ license:cc-by-sa3.0))))
+(define-public qelectrotech
+ (package
+ (name "qelectrotech")
+ (version "0.8.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://git.tuxfamily.org/qet/qet.git/"
+ "snapshot/qet-" version ".tar.gz"))
+ (sha256
+ (base32 "0w70fqwhqqzga1kfp34v8z1xf9988nvvi3d5gwl2sg429p9mpsk2"))))
+ (build-system qt-build-system)
+ (arguments
+ ;; XXX: tests are built for the CMake build option but it seems to be
+ ;; broken in 0.8.0.
+ `(#:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'configure
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ ;; Patch hardcoded path before running qmake.
+ (substitute* "qelectrotech.pro" (("\\/usr\\/local") out))
+ (invoke "qmake")))))))
+ (native-inputs
+ (list pkg-config qttools))
+ (inputs
+ (list kcoreaddons kwidgetsaddons qtbase-5 qtsvg sqlite))
+ (home-page "https://qelectrotech.org/")
+ (synopsis "CAD/CAE editor focusing on schematics drawing features")
+ (description "QElectroTech, or QET in short, is a desktop application to
+create diagrams and schematics. The software is primarily intended to create
+electrical documentation but it can also be used to draw any kinds of diagrams,
+such as those made in pneumatics, hydraulics, process industries, electronics,
+and others.")
+ (license license:gpl2+)))
+
(define-public gerbv
(package
(name "gerbv")