summaryrefslogtreecommitdiff
path: root/gnu/packages/enchant.scm
diff options
context:
space:
mode:
authorMarek Benc <merkur32@gmail.com>2014-09-09 13:34:22 +0200
committerLudovic Courtès <ludo@gnu.org>2014-09-09 13:34:22 +0200
commit1deac3440cc06060494bc821b2325cdf326b5696 (patch)
tree5b273e1e7a3b7f1b1f5269d636f7390bbe472ac0 /gnu/packages/enchant.scm
parent9ffbe2b7d5097aa376c1ea6fc461af47e71a64d1 (diff)
downloadguix-patches-1deac3440cc06060494bc821b2325cdf326b5696.tar
guix-patches-1deac3440cc06060494bc821b2325cdf326b5696.tar.gz
gnu: Add Enchant.
* gnu/packages/enchant.scm: New file. * gnu-system.am (GNU_SYSTEM_MODULES): Add it. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/enchant.scm')
-rw-r--r--gnu/packages/enchant.scm61
1 files changed, 61 insertions, 0 deletions
diff --git a/gnu/packages/enchant.scm b/gnu/packages/enchant.scm
new file mode 100644
index 0000000000..c9e49d9551
--- /dev/null
+++ b/gnu/packages/enchant.scm
@@ -0,0 +1,61 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2014 Marek Benc <merkur32@gmail.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages enchant)
+ #:use-module (gnu packages)
+ #:use-module (gnu packages aspell)
+ #:use-module (gnu packages glib)
+ #:use-module (gnu packages pkg-config)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix build-system gnu)
+ #:use-module (guix licenses))
+
+(define-public enchant
+ (package
+ (name "enchant")
+ (version "1.6.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append "http://www.abisource.com/downloads/" name "/" version
+ "/" name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0zq9yw1xzk8k9s6x83n1f9srzcwdavzazn3haln4nhp9wxxrxb1g"))))
+
+ (build-system gnu-build-system)
+ (inputs
+ `(("aspell" ,aspell) ;; Currently, the only supported backend in Guix
+ ("glib" ,glib))) ;; is aspell. (This information might be old)
+ (native-inputs
+ `(("glib:bin" ,glib "bin")
+ ("pkg-config" ,pkg-config)))
+
+ (synopsis "Multi-backend spell-checking library wrapper")
+ (description
+ "On the surface, Enchant appears to be a generic spell checking library.
+Looking closer, you'll see the Enchant is more-or-less a fancy wrapper around
+the dlopen() system call.
+
+Enchant steps in to provide uniformity and conformity on top of these libraries,
+and implement certain features that may be lacking in any individual provider
+library. Everything should \"just work\" for any and every definition of \"just
+working.\"")
+ (home-page "http://www.abisource.com/projects/enchant")
+ (license lgpl2.1+)))