summaryrefslogtreecommitdiff
path: root/gnu/packages/emulators.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-10-04 23:50:47 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-10-05 01:36:23 +0200
commitda878d7380c144ed8183e9369b46bdcd11ecd683 (patch)
treece0853c6c5e1798b1a026d9c5ae9300103671637 /gnu/packages/emulators.scm
parent365a9947386d9a18a4975c720c4cce2caa9f37de (diff)
downloadguix-patches-da878d7380c144ed8183e9369b46bdcd11ecd683.tar
guix-patches-da878d7380c144ed8183e9369b46bdcd11ecd683.tar.gz
gnu: sameboy: Update to 0.14.5.
* gnu/packages/emulators.scm (sameboy): Update to 0.14.5. [arguments]: Don't explicitly return #t from phases.
Diffstat (limited to 'gnu/packages/emulators.scm')
-rw-r--r--gnu/packages/emulators.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/emulators.scm b/gnu/packages/emulators.scm
index 77a45afe0b..b1ca968530 100644
--- a/gnu/packages/emulators.scm
+++ b/gnu/packages/emulators.scm
@@ -769,7 +769,7 @@ and Game Boy Color games.")
(define-public sameboy
(package
(name "sameboy")
- (version "0.14.4")
+ (version "0.14.5")
(source
(origin
(method git-fetch)
@@ -778,7 +778,7 @@ and Game Boy Color games.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0zp11qm8b3cmx70pzczyh4vv4jyhlh4jnci8kn6b30c8lzl43g83"))))
+ (base32 "0qqribyksm51fhq923rdhrzb9c4yf16szymprbw8fsz0nzv8frm3"))))
(build-system gnu-build-system)
(native-inputs
`(("rgbds" ,rgbds)
@@ -803,8 +803,7 @@ and Game Boy Color games.")
(with-directory-excursion "build/bin/SDL"
(install-file "sameboy" bin)
(delete-file "sameboy")
- (copy-recursively "." data))
- #t))))))
+ (copy-recursively "." data))))))))
(home-page "https://sameboy.github.io/")
(synopsis "Accurate Game Boy, Game Boy Color and Super Game Boy emulator")
(description "SameBoy is a user friendly Game Boy, Game Boy Color