summaryrefslogtreecommitdiff
path: root/gnu/packages/emulators.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2021-10-12 16:50:47 +0000
committerMathieu Othacehe <othacehe@gnu.org>2021-10-12 17:46:23 +0000
commita1eca979fb8da842e73c42f4f53be29b169810f2 (patch)
tree681c7283e412bb8a29c2531c4408b49c3e184764 /gnu/packages/emulators.scm
parent48d86a9ec6d8d2e97da2299ea41a03ef4cdaab83 (diff)
parent371aa5777a3805a3886f3feea5f1960fe3fe4219 (diff)
downloadguix-patches-a1eca979fb8da842e73c42f4f53be29b169810f2.tar
guix-patches-a1eca979fb8da842e73c42f4f53be29b169810f2.tar.gz
Merge remote-tracking branch 'origin/master' into core-updates-frozen.
Diffstat (limited to 'gnu/packages/emulators.scm')
-rw-r--r--gnu/packages/emulators.scm90
1 files changed, 34 insertions, 56 deletions
diff --git a/gnu/packages/emulators.scm b/gnu/packages/emulators.scm
index c992ba5407..ca7c91df04 100644
--- a/gnu/packages/emulators.scm
+++ b/gnu/packages/emulators.scm
@@ -48,10 +48,11 @@
#:use-module (gnu packages audio)
#:use-module (gnu packages autogen)
#:use-module (gnu packages autotools)
+ #:use-module (gnu packages backup)
#:use-module (gnu packages base)
#:use-module (gnu packages bison)
#:use-module (gnu packages boost)
- #:use-module (gnu packages backup)
+ #:use-module (gnu packages build-tools)
#:use-module (gnu packages cdrom)
#:use-module (gnu packages check)
#:use-module (gnu packages compression)
@@ -60,6 +61,7 @@
#:use-module (gnu packages digest)
#:use-module (gnu packages elf)
#:use-module (gnu packages flex)
+ #:use-module (gnu packages fltk)
#:use-module (gnu packages fonts)
#:use-module (gnu packages fontutils)
#:use-module (gnu packages freedesktop)
@@ -102,6 +104,7 @@
#:use-module (guix build-system cmake)
#:use-module (guix build-system glib-or-gtk)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system meson)
#:use-module (guix build-system python))
(define-public vice
@@ -400,7 +403,7 @@ older games.")
;; This is not a patch staging area for DOSBox, but an unaffiliated fork.
(package
(name "dosbox-staging")
- (version "0.76.0")
+ (version "0.77.1")
(source
(origin
(method git-fetch)
@@ -409,34 +412,20 @@ older games.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "14zlkm9qmaq2x4zdiadczsxvdnrf35w13ccvkxzd8cwrzxv84fvd"))))
- (build-system gnu-build-system)
+ (base32 "07jwmmm1bhfxavlhl854cj8l5iy5hqx5hpwkkjbcwqg7yh9jfs2x"))))
+ (build-system meson-build-system)
(arguments
- `(#:configure-flags
- (let* ((flags (list "-O3"
- ;; From scripts/automator/build/gcc-defaults.
- "-fstrict-aliasing"
- "-fno-signed-zeros"
- "-fno-trapping-math"
- "-fassociative-math"
- "-frename-registers"
- "-ffunction-sections"
- "-fdata-sections"))
- (CFLAGS (string-join flags " ")))
- ;; Several files #include <SDL_net.h> instead of <SDL2/SDL_net.h>,
- ;; including configure.ac itself.
- (list (string-append "CPPFLAGS=-I" (assoc-ref %build-inputs "sdl2")
- "/include/SDL2")
- (string-append "CFLAGS=" CFLAGS)
- (string-append "CXXFLAGS=-DNDEBUG " CFLAGS)))))
+ `(#:meson ,meson-0.55 #:configure-flags
+ ;; These both try to git clone subprojects.
+ (list "-Dunit_tests=disabled" ; gtest
+ "-Duse_mt32emu=false"))) ; mt32emu
(native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("pkg-config" ,pkg-config)))
+ `(("pkg-config" ,pkg-config)))
(inputs
`(("alsa-lib" ,alsa-lib)
("fluidsynth" ,fluidsynth)
("libpng" ,libpng)
+ ("mesa" ,mesa)
("opusfile" ,opusfile)
("sdl2" ,(sdl-union (list sdl2 sdl2-net)))
("zlib" ,zlib)))
@@ -782,7 +771,7 @@ and Game Boy Color games.")
(define-public sameboy
(package
(name "sameboy")
- (version "0.14.4")
+ (version "0.14.5")
(source
(origin
(method git-fetch)
@@ -791,7 +780,7 @@ and Game Boy Color games.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0zp11qm8b3cmx70pzczyh4vv4jyhlh4jnci8kn6b30c8lzl43g83"))))
+ (base32 "0qqribyksm51fhq923rdhrzb9c4yf16szymprbw8fsz0nzv8frm3"))))
(build-system gnu-build-system)
(native-inputs
`(("rgbds" ,rgbds)
@@ -816,8 +805,7 @@ and Game Boy Color games.")
(with-directory-excursion "build/bin/SDL"
(install-file "sameboy" bin)
(delete-file "sameboy")
- (copy-recursively "." data))
- #t))))))
+ (copy-recursively "." data))))))))
(home-page "https://sameboy.github.io/")
(synopsis "Accurate Game Boy, Game Boy Color and Super Game Boy emulator")
(description "SameBoy is a user friendly Game Boy, Game Boy Color
@@ -1371,7 +1359,7 @@ towards a working Mupen64Plus for casual users.")
(define-public nestopia-ue
(package
(name "nestopia-ue")
- (version "1.48")
+ (version "1.51.1")
(source
(origin
(method git-fetch)
@@ -1380,36 +1368,24 @@ towards a working Mupen64Plus for casual users.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "19c8vx5yxbysl0sszk5blfngwacshdgwbf44g1qaxvq8ywiyxmb4"))
- (modules '((guix build utils)))
- (snippet
- '(begin
- ;; We don't need libretro for the GNU/Linux build.
- (delete-file-recursively "libretro")
- #t))))
- (build-system cmake-build-system)
+ (base32 "1g19gz33jav00rwzkpcnynf5ps41vl64a9qx0xjd6lva4bgn8s57"))))
+ (build-system gnu-build-system)
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ `(("autoconf" ,autoconf)
+ ("autoconf-archive" ,autoconf-archive)
+ ("automake" ,automake)
+ ("pkg-config" ,pkg-config)))
(inputs
- `(("ao" ,ao)
- ("gtk+" ,gtk+)
+ `(("fltk" ,fltk)
+ ("fontconfig", fontconfig)
("libarchive" ,libarchive)
("libepoxy" ,libepoxy)
+ ("libxft" ,libxft)
+ ("libxrender" ,libxrender)
("sdl2" ,sdl2)
("zlib" ,zlib)))
(arguments
- '(#:phases
- (modify-phases %standard-phases
- ;; This fixes the file chooser crash that happens with GTK 3.
- (add-after 'install 'wrap-program
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (nestopia (string-append out "/bin/nestopia"))
- (gtk (assoc-ref inputs "gtk+"))
- (gtk-share (string-append gtk "/share")))
- (wrap-program nestopia
- `("XDG_DATA_DIRS" ":" prefix (,gtk-share)))))))
- ;; There are no tests.
+ '(;; There are no tests.
#:tests? #f))
(home-page "http://0ldsk00l.ca/nestopia/")
(synopsis "Nintendo Entertainment System (NES/Famicom) emulator")
@@ -1550,14 +1526,14 @@ multi-system game/emulator system.")
(define-public scummvm
(package
(name "scummvm")
- (version "2.2.0")
+ (version "2.5.0")
(source
(origin
(method url-fetch)
(uri (string-append "https://downloads.scummvm.org/frs/scummvm/" version
"/scummvm-" version ".tar.xz"))
(sha256
- (base32 "11vknasm5dna2vqr6gk343qynh7nhsq3kf60zayarn1vb5z6as8l"))))
+ (base32 "08ynw1cmld41p4bwrw84gb1nv229va70i91qiqsjr3c2jnqy8zml"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ;require "git"
@@ -1584,6 +1560,8 @@ multi-system game/emulator system.")
("fluidsynth" ,fluidsynth)
("freetype" ,freetype)
("fribidi" ,fribidi)
+ ("glew" ,glew)
+ ("giflib" ,giflib)
("liba52" ,liba52)
("libflac" ,flac)
("libjpeg-turbo" ,libjpeg-turbo)
@@ -1774,7 +1752,7 @@ This is a part of the TiLP project.")
(define-public mame
(package
(name "mame")
- (version "0.235")
+ (version "0.236")
(source
(origin
(method git-fetch)
@@ -1783,7 +1761,7 @@ This is a part of the TiLP project.")
(commit (apply string-append "mame" (string-split version #\.)))))
(file-name (git-file-name name version))
(sha256
- (base32 "1iz5p51am7gh19i0zx96vfpfpza8xvrz9f2pd908jsc4xpr36agd"))
+ (base32 "0pxvvdirbwakl5cy7lp0zib6z176ckxx8c3mazsd7q1ddxxd3l8x"))
(modules '((guix build utils)))
(snippet
;; Remove bundled libraries.