summaryrefslogtreecommitdiff
path: root/gnu/packages/emulators.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2020-06-16 22:51:39 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-06-29 17:05:12 +0200
commit6dd2ad26d0f82b86f0ef0bbff04229b39b165e33 (patch)
tree58d8feb4ce7858c773a4bfffc3563d8c435e30d6 /gnu/packages/emulators.scm
parentc47485b27c1a464dbcc96aa2cf4b4590731320ec (diff)
downloadguix-patches-6dd2ad26d0f82b86f0ef0bbff04229b39b165e33.tar
guix-patches-6dd2ad26d0f82b86f0ef0bbff04229b39b165e33.tar.gz
gnu: Add mednafen.
* gnu/packages/emulators.scm (mednafen): New variable.
Diffstat (limited to 'gnu/packages/emulators.scm')
-rw-r--r--gnu/packages/emulators.scm61
1 files changed, 61 insertions, 0 deletions
diff --git a/gnu/packages/emulators.scm b/gnu/packages/emulators.scm
index 5525b066f4..ae8bf18255 100644
--- a/gnu/packages/emulators.scm
+++ b/gnu/packages/emulators.scm
@@ -414,6 +414,67 @@ Pocket Color, WonderSwan, WonderSwan Color, SwanCrystal, Pocket Challenge
V2.")
(license license:gpl3+)))
+(define-public mednafen
+ (package
+ (name "mednafen")
+ (version "1.24.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://mednafen.github.io/releases/files/"
+ "mednafen-" version ".tar.xz"))
+ (sha256
+ (base32 "03zplcfvmnnv7grhacmr1zy789pb2wda36wylmzmar23g0zqbsix"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags
+ (list
+ ;; "--with-external-mpcdec"
+ "--with-external-lzo")))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("alsa" ,alsa-lib)
+ ;; ("libmpcdec" ,libmpcdec) FIXME: not recognized.
+ ("libsndfile" ,libsndfile)
+ ("lzo" ,lzo)
+ ("sdl2" ,sdl2)
+ ("zlib" ,zlib)))
+ (home-page "https://mednafen.github.io/")
+ (synopsis "Multi-system emulator utilizing OpenGL and SDL")
+ (description
+ "Mednafen is a portable, utilizing OpenGL and SDL, argument-driven
+multi-system emulator. Mednafen has the ability to remap hotkey functions and
+virtual system inputs to a keyboard, a joystick, or both simultaneously. Save
+states are supported, as is real-time game rewinding. Screen snapshots may be
+taken, in the PNG file format, at the press of a button. Mednafen can record
+audiovisual movies in the QuickTime file format, with several different
+lossless codecs supported.
+
+The following systems are supported:
+
+@itemize
+@item Apple II/II+
+@item Atari Lynx
+@item Neo Geo Pocket (Color)
+@item WonderSwan
+@item GameBoy (Color)
+@item GameBoy Advance
+@item Nintendo Entertainment System
+@item Super Nintendo Entertainment System/Super Famicom
+@item Virtual Boy
+@item PC Engine/TurboGrafx 16 (CD)
+@item SuperGrafx
+@item PC-FX
+@item Sega Game Gear
+@item Sega Genesis/Megadrive
+@item Sega Master System
+@item Sega Saturn (experimental, x86_64 only)
+@item Sony PlayStation
+@end itemize")
+ ;; Main license is GPL2+. Some parts are BSD-3.
+ (license (list license:gpl2+ license:bsd-3))))
+
(define-public mgba
(package
(name "mgba")