summaryrefslogtreecommitdiff
path: root/gnu/packages/emulators.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2019-11-21 16:37:40 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2019-11-21 16:37:40 +0100
commit430e152899120e94a81eed08122f5cbf8f327874 (patch)
treeab745d155d225dfe9ba4e9dfc55e49332bdeb9b7 /gnu/packages/emulators.scm
parentab9d06e473f74a3ed33944ea1aaa99f10c485bfd (diff)
downloadguix-patches-430e152899120e94a81eed08122f5cbf8f327874.tar
guix-patches-430e152899120e94a81eed08122f5cbf8f327874.tar.gz
gnu: mame: Fix build on i686.
* gnu/packages/emulators.scm (mame): Prevent strict-overflow error on i686 with "NOWERROR" flag.
Diffstat (limited to 'gnu/packages/emulators.scm')
-rw-r--r--gnu/packages/emulators.scm2
1 files changed, 2 insertions, 0 deletions
diff --git a/gnu/packages/emulators.scm b/gnu/packages/emulators.scm
index 72a9b6e40d..577894cbe2 100644
--- a/gnu/packages/emulators.scm
+++ b/gnu/packages/emulators.scm
@@ -1213,6 +1213,8 @@ play them on systems for which they were never designed!")
(arguments
`(#:make-flags
(cons*
+ ;; A 'strict-overflow' error pops up on i686 so disable '-Werror'.
+ "NOWERROR=1"
(string-append "QT_HOME=" (assoc-ref %build-inputs "qtbase"))
(string-append "SDL_INI_PATH="
(assoc-ref %outputs "out")