summaryrefslogtreecommitdiff
path: root/gnu/packages/emulators.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-11-22 22:40:00 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-11-22 22:40:00 +0100
commit3e678de04c86b99d4a7c0128a975e40a3a59f2cc (patch)
tree8d778e897b0c2530f5a9ba51233e78f3be13704e /gnu/packages/emulators.scm
parent3d109b030603ac2f2e3da1f7b048d80193a92077 (diff)
downloadguix-patches-3e678de04c86b99d4a7c0128a975e40a3a59f2cc.tar
guix-patches-3e678de04c86b99d4a7c0128a975e40a3a59f2cc.tar.gz
gnu: mupen64plus-core: Add -fcommon to CFLAGS.
* gnu/packages/emulators.scm (mupen64plus-core)[arguments]: Replace 'configure phase to patch Makefile; remove trailing #T from 'chdir-to-project-directory phase.
Diffstat (limited to 'gnu/packages/emulators.scm')
-rw-r--r--gnu/packages/emulators.scm13
1 files changed, 7 insertions, 6 deletions
diff --git a/gnu/packages/emulators.scm b/gnu/packages/emulators.scm
index 407e9bec53..5559b2e732 100644
--- a/gnu/packages/emulators.scm
+++ b/gnu/packages/emulators.scm
@@ -842,13 +842,14 @@ from an emulator---from save states to scaling filters.")
'(#:phases
(modify-phases %standard-phases
;; The mupen64plus build system has no configure phase.
- (delete 'configure)
+ (replace 'configure
+ (lambda _
+ (substitute* "projects/unix/Makefile"
+ (("\\$\\(CFLAGS\\)")
+ "$(CFLAGS) -fcommon"))))
;; Makefile is in a subdirectory.
- (add-before
- 'build 'chdir-to-project-directory
- (lambda _
- (chdir "projects/unix")
- #t)))
+ (add-before 'build 'chdir-to-project-directory
+ (lambda _ (chdir "projects/unix"))))
#:make-flags (let ((out (assoc-ref %outputs "out")))
(list "all" (string-append "PREFIX=" out)))
;; There are no tests.