summaryrefslogtreecommitdiff
path: root/gnu/packages/emulators.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-05-01 23:11:41 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-05-01 23:11:41 +0200
commit3b458d5462e6bbd852c2dc5c6670d5655abf53f5 (patch)
tree4f3ccec0de1c355134369333c17e948e3258d546 /gnu/packages/emulators.scm
parent2ca3fdc2db1aef96fbf702a2f26f5e18ce832038 (diff)
parent14da3daafc8dd92fdabd3367694c930440fd72cb (diff)
downloadguix-patches-3b458d5462e6bbd852c2dc5c6670d5655abf53f5.tar
guix-patches-3b458d5462e6bbd852c2dc5c6670d5655abf53f5.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/emulators.scm')
-rw-r--r--gnu/packages/emulators.scm169
1 files changed, 85 insertions, 84 deletions
diff --git a/gnu/packages/emulators.scm b/gnu/packages/emulators.scm
index b02e450f3e..bb5addd4a2 100644
--- a/gnu/packages/emulators.scm
+++ b/gnu/packages/emulators.scm
@@ -460,13 +460,13 @@ and Game Boy Color games.")
(version "2.5")
(source
(origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/mupen64plus/mupen64plus-core/archive/"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mupen64plus/mupen64plus-core.git")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
- (base32 "0dg2hksm5qni2hcha93k7n4fqr92888p946f7phb0ndschzfh9kk"))))
+ (base32 "116fndl6652zrp1r6ag4xv3dzp1x52mlvadj8xwflq07fd5rhri1"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)
@@ -508,13 +508,13 @@ core library.")
(version "2.5")
(source
(origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/mupen64plus/mupen64plus-audio-sdl/archive/"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mupen64plus/mupen64plus-audio-sdl.git")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
- (base32 "0ss6w92n2rpfnazhg9lbq0nvs3fqx93nliz3k3wjxdlx4dpi7h3a"))))
+ (base32 "0z19amfg9vr2pqjjri1ipc7hs681fzjcnb0f9y7bjhp5n8d7p6bb"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)
@@ -554,13 +554,13 @@ SDL audio plugin.")
(version "2.5")
(source
(origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/mupen64plus/mupen64plus-input-sdl/archive/"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mupen64plus/mupen64plus-input-sdl.git")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
- (base32 "11sj5dbalp2nrlmki34vy7wy28vc175pnnkdk65p8599hnyq37ri"))))
+ (base32 "1dyazfbdjycdfslq8jixqiqhziw0rlkvach2r9dz91229jmkyc9c"))))
(build-system gnu-build-system)
(native-inputs
`(("which" ,which)))
@@ -599,13 +599,13 @@ SDL input plugin.")
(version "2.5")
(source
(origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/mupen64plus/mupen64plus-rsp-hle/archive/"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mupen64plus/mupen64plus-rsp-hle.git")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
- (base32 "15h7mgz6xd2zjzm6l3f96sbs8kwr3xvbwzgikhnka79m6c69hsxv"))))
+ (base32 "0pi31qzjjp7aypdvvnz6ms18g09c4gqzxi6328zj8sji94b75gf0"))))
(build-system gnu-build-system)
(inputs
`(("mupen64plus-core" ,mupen64plus-core)))
@@ -641,13 +641,13 @@ high-level emulation (HLE) RSP processor plugin.")
(version "2.0.0")
(source
(origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/mupen64plus/mupen64plus-rsp-z64/archive/"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mupen64plus/mupen64plus-rsp-z64.git")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
- (base32 "10jz1w2dhx5slhyk4m8mdqlpsd6cshchslr1fckb2ayzb1ls3ghi"))))
+ (base32 "0nfyjns9k8xbg3aqs7593nfaxvlj72h3l8h467442xlk8ajfcylx"))))
(build-system gnu-build-system)
(inputs
`(("mupen64plus-core" ,mupen64plus-core)))
@@ -683,13 +683,13 @@ Z64 RSP processor plugin.")
(version "2.0.0")
(source
(origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/mupen64plus/mupen64plus-video-arachnoid/archive/"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mupen64plus/mupen64plus-video-arachnoid.git")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
- (base32 "0jjwf144rihznm4lnqbhgigxw664v3v32wy94adaa6imk8z6gslh"))))
+ (base32 "1v9fqwpb6pawr8z5cm2ki7bqkks4iyr5c4jy4v5khj6h8zcv55gc"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)
@@ -729,13 +729,13 @@ Arachnoid video plugin.")
(version "2.0.0")
(source
(origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/mupen64plus/mupen64plus-video-glide64/archive/"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mupen64plus/mupen64plus-video-glide64.git")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
- (base32 "1rm55dbf6xgsq1blbzs6swa2ajv0qkn38acbljj346abnk6s3dla"))))
+ (base32 "0qn5za7g7796kh2ag3xpmhbqg0yf71g9liz6ks0rha8pz73lgs01"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)
@@ -783,13 +783,13 @@ Glide64 video plugin.")
(version "2.5")
(source
(origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/mupen64plus/mupen64plus-video-glide64mk2/archive/"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mupen64plus/mupen64plus-video-glide64mk2.git")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
- (base32 "1ihl4q293d6svba26b4mhapjcdg12p90gibz79b4mx423jlcxxj9"))))
+ (base32 "08pm28a36dpr0cvr8pzw0n5ksdazp7jqvlmqfy2lwb4dm0cwhkqd"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)
@@ -833,13 +833,13 @@ Glide64MK2 video plugin.")
(version "2.5")
(source
(origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/mupen64plus/mupen64plus-video-rice/archive/"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mupen64plus/mupen64plus-video-rice.git")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
- (base32 "0rd2scjmh285w61aj3mgx71whg5rqrjbry3cdgicczrnyvf8wdvk"))))
+ (base32 "0rpmbcq67gsj5h5jjis146378qc1mskskvx20y1ikx59yhbamh13"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)
@@ -881,13 +881,13 @@ Rice Video plugin.")
(version "2.0.0")
(source
(origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/mupen64plus/mupen64plus-video-z64/archive/"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mupen64plus/mupen64plus-video-z64.git")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
- (base32 "1x7wsjs5gx2iwx20p4cjcbf696zsjlh31qxmghwv0ifrq8x58s1b"))
+ (base32 "04qa2fdd6dakpk2v0d4l80xh9b4h8gm71g80c0wyyxdhmhwk1r9c"))
(patches (search-patches "mupen64plus-video-z64-glew-correct-path.patch"))))
(build-system gnu-build-system)
(native-inputs
@@ -936,13 +936,13 @@ Z64 video plugin.")
(version "2.5")
(source
(origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/mupen64plus/mupen64plus-ui-console/archive/"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mupen64plus/mupen64plus-ui-console.git")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
- (base32 "04qkpd8ic7xsgnqz7spl00wxdygf79m7d1k8rabbygjk5lg6p8z2"))
+ (base32 "0vrf98qa6a0y3647kslsv644fag233dxh5dcr1yncjiiwickcr5a"))
(patches (search-patches "mupen64plus-ui-console-notice.patch"))))
(build-system gnu-build-system)
(native-inputs
@@ -999,21 +999,21 @@ towards a working Mupen64Plus for casual users.")
(package
(name "nestopia-ue")
(version "1.48")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/rdanbrook/nestopia/archive/"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "184y05z4k4a4m4022niy625kan0rklh8gcxyynxli1fss2sjjrpv"))
- (modules '((guix build utils)))
- (snippet
- '(begin
- ;; We don't need libretro for the GNU/Linux build.
- (delete-file-recursively "libretro")
- #t))))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rdanbrook/nestopia.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "19c8vx5yxbysl0sszk5blfngwacshdgwbf44g1qaxvq8ywiyxmb4"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; We don't need libretro for the GNU/Linux build.
+ (delete-file-recursively "libretro")
+ #t))))
(build-system cmake-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)))
@@ -1185,7 +1185,7 @@ play them on systems for which they were never designed!")
(define-public mame
(package
(name "mame")
- (version "0.206")
+ (version "0.209")
(source
(origin
(method git-fetch)
@@ -1195,7 +1195,7 @@ play them on systems for which they were never designed!")
(file-name (git-file-name name version))
(sha256
(base32
- "0i01h5ars1yd96ndmzhk47931hf261m8frqz1ha7s2gy52f0q86y"))
+ "08qvwmx8wbfkqxiccmcff86dsrlq6wjxf6blnhhrsbzic1ji99bh"))
(modules '((guix build utils)))
(snippet
;; Remove bundled libraries.
@@ -1333,7 +1333,8 @@ play them on systems for which they were never designed!")
#t))))))
(native-inputs
`(("pkg-config" ,pkg-config)
- ("python-sphinx" ,python-sphinx)
+ ("sphinx" ,python-sphinx)
+ ("sphinxcontrib-svg2pdfconverter" ,python-sphinxcontrib-svg2pdfconverter)
("texinfo" ,texinfo)))
(inputs
`(("alsa-lib" ,alsa-lib)