summaryrefslogtreecommitdiff
path: root/gnu/packages/emulators.scm
diff options
context:
space:
mode:
authorJakub Kądziołka <kuba@kadziolka.net>2020-02-23 13:43:50 +0100
committerJakub Kądziołka <kuba@kadziolka.net>2020-02-23 13:45:45 +0100
commit1d0e8ec19e1810c242df2e46f01d956c0d29dc2a (patch)
treea28f9f43d620aeabe5fb085279db8115d9ea2e52 /gnu/packages/emulators.scm
parent7da1e8f9b4545faeda19b58f59e135b205f197da (diff)
downloadguix-patches-1d0e8ec19e1810c242df2e46f01d956c0d29dc2a.tar
guix-patches-1d0e8ec19e1810c242df2e46f01d956c0d29dc2a.tar.gz
gnu: mgba: Update to 0.8.1.
* gnu/packages/emulators.scm (mgba): Update to 0.8.1. [inputs, native-inputs]: Move qttools to native-inputs as per guix lint (guix size says it's not used at runtime). [license]: Add expat for src/third-party/discord-rpc.
Diffstat (limited to 'gnu/packages/emulators.scm')
-rw-r--r--gnu/packages/emulators.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/emulators.scm b/gnu/packages/emulators.scm
index b7f29a6f5b..92e50d1484 100644
--- a/gnu/packages/emulators.scm
+++ b/gnu/packages/emulators.scm
@@ -419,7 +419,7 @@ Super Game Boy, BS-X Satellaview, and Sufami Turbo.")
(define-public mgba
(package
(name "mgba")
- (version "0.8.0")
+ (version "0.8.1")
(source
(origin
(method git-fetch)
@@ -428,7 +428,7 @@ Super Game Boy, BS-X Satellaview, and Sufami Turbo.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0m3rgcdv32ms98j7rrmk2hphvn462bwsd6xfz2ssy05398pj4ljh"))
+ (base32 "1if82mfaak3696w5d5yshynpzywrxgvg3ifdfi2rwlpvq1gpd429"))
(modules '((guix build utils)))
(snippet
;; Make sure we don't use the bundled software.
@@ -445,7 +445,8 @@ Super Game Boy, BS-X Satellaview, and Sufami Turbo.")
#:configure-flags
(list "-DUSE_LZMA=OFF" ;do not use bundled LZMA
"-DUSE_LIBZIP=OFF"))) ;use "zlib" instead
- (native-inputs `(("pkg-config" ,pkg-config)))
+ (native-inputs `(("pkg-config" ,pkg-config)
+ ("qttools" ,qttools)))
(inputs `(("ffmpeg" ,ffmpeg)
("imagemagick" ,imagemagick)
("libedit" ,libedit)
@@ -457,7 +458,6 @@ Super Game Boy, BS-X Satellaview, and Sufami Turbo.")
("ncurses" ,ncurses)
("qtbase" ,qtbase)
("qtmultimedia" ,qtmultimedia)
- ("qttools" ,qttools)
("sdl2" ,sdl2)
("sqlite" ,sqlite)
("zlib" ,zlib)))
@@ -468,9 +468,9 @@ Super Game Boy, BS-X Satellaview, and Sufami Turbo.")
faster and more accurate than many existing Game Boy Advance emulators, as
well as adding features that other emulators lack. It also supports Game Boy
and Game Boy Color games.")
- ;; Code is mainly MPL 2.0. "blip_buf.c" is LGPL 2.1+ and "inih.c" is
- ;; BSD-3.
- (license (list license:mpl2.0 license:lgpl2.1+ license:bsd-3))))
+ ;; Code is mainly MPL 2.0. "blip_buf.c" is LGPL 2.1+, "inih.c" is
+ ;; BSD-3, and "discord-rpc" is Expat.
+ (license (list license:mpl2.0 license:lgpl2.1+ license:bsd-3 license:expat))))
(define-public sameboy
(package