summaryrefslogtreecommitdiff
path: root/gnu/packages/embedded.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-11-09 23:27:22 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-11-10 18:19:39 +0100
commite35f77e1188092ddd2719b79bcdaf364458b837a (patch)
tree989d2c9524f2e9117ee6c378d2cc07bbee482781 /gnu/packages/embedded.scm
parent3881d0dc413b482ae1fd11aa09c263839ddde7a5 (diff)
downloadguix-patches-e35f77e1188092ddd2719b79bcdaf364458b837a.tar
guix-patches-e35f77e1188092ddd2719b79bcdaf364458b837a.tar.gz
gnu: jimtcl: Update to 0.80.
* gnu/packages/embedded.scm (jimtcl): Update to 0.80. [arguments]: Add a ‘delete-failing-tests’ phase. [native-inputs]: Add inetutils.
Diffstat (limited to 'gnu/packages/embedded.scm')
-rw-r--r--gnu/packages/embedded.scm20
1 files changed, 15 insertions, 5 deletions
diff --git a/gnu/packages/embedded.scm b/gnu/packages/embedded.scm
index cc26b17ea6..3a64c75109 100644
--- a/gnu/packages/embedded.scm
+++ b/gnu/packages/embedded.scm
@@ -3,7 +3,7 @@
;;; Copyright © 2016, 2017 Theodoros Foradis <theodoros@foradis.org>
;;; Copyright © 2016 David Craven <david@craven.ch>
;;; Copyright © 2017, 2020 Efraim Flashner <efraim@flashner.co.il>
-;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018, 2019 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2020 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
@@ -36,6 +36,7 @@
#:use-module (guix build-system trivial)
#:use-module ((guix build utils) #:select (alist-replace))
#:use-module (gnu packages)
+ #:use-module (gnu packages admin)
#:use-module (gnu packages autotools)
#:use-module ((gnu packages base) #:prefix base:)
#:use-module (gnu packages bison)
@@ -487,7 +488,7 @@ SEGGER J-Link and compatible devices.")
(define-public jimtcl
(package
(name "jimtcl")
- (version "0.79")
+ (version "0.80")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -496,17 +497,26 @@ SEGGER J-Link and compatible devices.")
(file-name (git-file-name name version))
(sha256
(base32
- "1k88hz0v3bi19xdvlp0i9nsx38imzwpjh632w7326zwbv2wldf0h"))))
+ "06rn60cx9sapc175vxvan87b8j5rkhh5gvvz7343xznzwlr0wcgk"))))
(build-system gnu-build-system)
(arguments
`(#:phases
(modify-phases %standard-phases
- ;; Doesn't use autoconf.
(replace 'configure
+ ;; This package doesn't use autoconf.
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
(invoke "./configure"
- (string-append "--prefix=" out))))))))
+ (string-append "--prefix=" out)))))
+ (add-before 'check 'delete-failing-tests
+ (lambda _
+ ;; XXX All but 1 TTY tests fail (Inappropriate ioctl for device).
+ (delete-file "tests/tty.test")
+ #t))
+ )))
+ (native-inputs
+ ;; For tests.
+ `(("inetutils" ,inetutils))) ; for hostname
(home-page "http://jim.tcl.tk/index.html")
(synopsis "Small footprint Tcl implementation")
(description "Jim is a small footprint implementation of the Tcl programming