summaryrefslogtreecommitdiff
path: root/gnu/packages/embedded.scm
diff options
context:
space:
mode:
authorMorgan Smith <Morgan.J.Smith@outlook.com>2020-11-30 12:20:04 -0500
committerMathieu Othacehe <othacehe@gnu.org>2020-12-01 11:08:57 +0100
commitdcb95c6fc1cee5a74146f4f062d83a8f8c8d4cd0 (patch)
treee6777716e383a574eb5b5c6f69c4469c00c57bab /gnu/packages/embedded.scm
parent2c0b331c9a2b58dee6863050b4b798b112cfb909 (diff)
downloadguix-patches-dcb95c6fc1cee5a74146f4f062d83a8f8c8d4cd0.tar
guix-patches-dcb95c6fc1cee5a74146f4f062d83a8f8c8d4cd0.tar.gz
gnu: openocd: Fix build.
* gnu/packages/embedded.scm (openocd)[arguments]: Add "LIBS=-lutil" to allow it to build. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/embedded.scm')
-rw-r--r--gnu/packages/embedded.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/embedded.scm b/gnu/packages/embedded.scm
index d6f487bd17..f2c7ca5f9f 100644
--- a/gnu/packages/embedded.scm
+++ b/gnu/packages/embedded.scm
@@ -554,7 +554,8 @@ language.")
("libusb-compat" ,libusb-compat)))
(arguments
'(#:configure-flags
- (append (list "--disable-werror"
+ (append (list "LIBS=-lutil"
+ "--disable-werror"
"--enable-sysfsgpio"
"--disable-internal-jimtcl"
"--disable-internal-libjaylink")