summaryrefslogtreecommitdiff
path: root/gnu/packages/embedded.scm
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2020-06-15 17:42:43 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2020-09-07 00:19:54 +0200
commitbbf8a309662c8378b817cfb760447cd6f8ce59e8 (patch)
treec860af02ca314c92e9f0d4ce12a31261b0104580 /gnu/packages/embedded.scm
parentf70c2bd900fd7fe9695b924147bd278c4c0cbef4 (diff)
downloadguix-patches-bbf8a309662c8378b817cfb760447cd6f8ce59e8.tar
guix-patches-bbf8a309662c8378b817cfb760447cd6f8ce59e8.tar.gz
gnu: Add ebusd.
* gnu/packages/embedded.scm (ebusd): New variable.
Diffstat (limited to 'gnu/packages/embedded.scm')
-rw-r--r--gnu/packages/embedded.scm47
1 files changed, 47 insertions, 0 deletions
diff --git a/gnu/packages/embedded.scm b/gnu/packages/embedded.scm
index 31fd7b05ce..3042ed1049 100644
--- a/gnu/packages/embedded.scm
+++ b/gnu/packages/embedded.scm
@@ -1357,3 +1357,50 @@ simplifies configuration and is also pluggable: you can write your own west
this feature to provide conveniences for building applications, flashing and
debugging them, and more.")
(license license:expat)))
+
+;; TODO: Support MQTT.
+(define-public ebusd
+ (package
+ (name "ebusd")
+ (version "3.4")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/john30/ebusd.git")
+ (commit (string-append "v" version))))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "0iva70bam7wdx60bpd3an9kxr28zxlvp3vprivgqshwwdhqa0hzp"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'install-config
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((config-destination
+ (string-append (assoc-ref outputs "out")
+ "/share/ebusd")))
+ (copy-recursively (string-append (assoc-ref inputs "config")
+ "/ebusd-2.1.x")
+ config-destination)
+ #t))))))
+ (native-inputs
+ `(("automake" ,automake)
+ ("autoconf" ,autoconf)
+ ("config"
+ ,(origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/john30/ebusd-configuration.git")
+ (commit "666c0f6b9c4d7545eff7f43ab28a1c7baeab7913")))
+ (file-name "config-checkout")
+ (sha256
+ (base32
+ "0yxnx8p4lbk614l16854r9s9d8s9c7ixgczfs8mph94xz0wkda7x"))))))
+ (synopsis "Daemon for communicating with eBUS devices")
+ (description "This package provides @command{ebusd}, a daemon for
+handling communication with eBUS devices connected to a 2-wire bus system
+(\"energy bus\" used by numerous heating systems).")
+ (home-page "https://ebusd.eu/")
+ (license license:gpl3+)))