summaryrefslogtreecommitdiff
path: root/gnu/packages/embedded.scm
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2021-12-16 20:11:40 +0100
committerDanny Milosavljevic <dannym@scratchpost.org>2021-12-16 21:31:43 +0100
commitb47fcf1cbeb31e2b68c020639d4c08acff0fefb1 (patch)
treed23c3e1aa13a5440c730f5e3933d5d337867489f /gnu/packages/embedded.scm
parent18d5e7c96bc642319245824a0a22d58846e73f10 (diff)
downloadguix-patches-b47fcf1cbeb31e2b68c020639d4c08acff0fefb1.tar
guix-patches-b47fcf1cbeb31e2b68c020639d4c08acff0fefb1.tar.gz
gnu: openocd: Update to 0.11.0.
* gnu/packages/embedded.scm (openocd): Update to 0.11.0.
Diffstat (limited to 'gnu/packages/embedded.scm')
-rw-r--r--gnu/packages/embedded.scm121
1 files changed, 59 insertions, 62 deletions
diff --git a/gnu/packages/embedded.scm b/gnu/packages/embedded.scm
index 1c8b76c11d..f0d86cf8da 100644
--- a/gnu/packages/embedded.scm
+++ b/gnu/packages/embedded.scm
@@ -565,69 +565,66 @@ language.")
(license license:bsd-2)))
(define-public openocd
- (let ((commit "9a877a83a1c8b1f105cdc0de46c5cbc4d9e8799e")
- (revision "0"))
- (package
- (name "openocd")
- (version (string-append "0.10.0-" revision "."
- (string-take commit 7)))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://git.code.sf.net/p/openocd/code")
- (commit commit)))
- (file-name (string-append name "-" version "-checkout"))
- (sha256
- (base32
- "1q536cp80v2bcy6xwk08f1r2ljyw13jchx3a1z7d3ni3vqql7rc6"))))
- (build-system gnu-build-system)
- (native-inputs
- (list autoconf
- automake
- libtool
- base:which
- pkg-config
- texinfo))
- (inputs
- (list hidapi jimtcl libftdi libjaylink libusb-compat))
- (arguments
- '(#:configure-flags
- (append (list "LIBS=-lutil"
- "--disable-werror"
- "--enable-sysfsgpio"
- "--disable-internal-jimtcl"
- "--disable-internal-libjaylink")
- (map (lambda (programmer)
- (string-append "--enable-" programmer))
- '("amtjtagaccel" "armjtagew" "buspirate" "ftdi"
- "gw16012" "jlink" "opendous" "osbdm"
- "parport" "aice" "cmsis-dap" "dummy" "jtag_vpi"
- "remote-bitbang" "rlink" "stlink" "ti-icdi" "ulink"
- "usbprog" "vsllink" "usb-blaster-2" "usb_blaster"
- "presto" "openjtag")))
- #:phases
- (modify-phases %standard-phases
- (replace 'bootstrap
- (lambda _
- (patch-shebang "bootstrap")
- (invoke "./bootstrap" "nosubmodule")))
- (add-after 'autoreconf 'change-udev-group
- (lambda _
- (substitute* "contrib/60-openocd.rules"
- (("plugdev") "dialout"))
- #t))
- (add-after 'install 'install-udev-rules
- (lambda* (#:key outputs #:allow-other-keys)
- (install-file "contrib/60-openocd.rules"
- (string-append
- (assoc-ref outputs "out")
- "/lib/udev/rules.d/"))
- #t)))))
- (home-page "http://openocd.org")
- (synopsis "On-Chip Debugger")
- (description "OpenOCD provides on-chip programming and debugging support
+ (package
+ (name "openocd")
+ (version "0.11.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.code.sf.net/p/openocd/code")
+ (commit (string-append "v" version))))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "0qi4sixwvw1i7c64sy221fsjs82qf3asmdk86g74ds2jjm3f8pzp"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ (list autoconf
+ automake
+ libtool
+ base:which
+ pkg-config
+ texinfo))
+ (inputs
+ (list hidapi jimtcl libftdi libjaylink libusb-compat))
+ (arguments
+ '(#:configure-flags
+ (append (list "LIBS=-lutil"
+ "--disable-werror"
+ "--enable-sysfsgpio"
+ "--disable-internal-jimtcl"
+ "--disable-internal-libjaylink")
+ (map (lambda (programmer)
+ (string-append "--enable-" programmer))
+ '("amtjtagaccel" "armjtagew" "buspirate" "ftdi"
+ "gw16012" "jlink" "opendous" "osbdm"
+ "parport" "aice" "cmsis-dap" "dummy" "jtag_vpi"
+ "remote-bitbang" "rlink" "stlink" "ti-icdi" "ulink"
+ "usbprog" "vsllink" "usb-blaster-2" "usb_blaster"
+ "presto" "openjtag")))
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'bootstrap
+ (lambda _
+ (patch-shebang "bootstrap")
+ (invoke "./bootstrap" "nosubmodule")))
+ (add-after 'autoreconf 'change-udev-group
+ (lambda _
+ (substitute* "contrib/60-openocd.rules"
+ (("plugdev") "dialout"))
+ #t))
+ (add-after 'install 'install-udev-rules
+ (lambda* (#:key outputs #:allow-other-keys)
+ (install-file "contrib/60-openocd.rules"
+ (string-append
+ (assoc-ref outputs "out")
+ "/lib/udev/rules.d/"))
+ #t)))))
+ (home-page "http://openocd.org")
+ (synopsis "On-Chip Debugger")
+ (description "OpenOCD provides on-chip programming and debugging support
with a layered architecture of JTAG interface and TAP support.")
- (license license:gpl2+))))
+ (license license:gpl2+)))
;; The commits for all propeller tools are the stable versions published at
;; https://github.com/propellerinc/propgcc in the release_1_0. According to