summaryrefslogtreecommitdiff
path: root/gnu/packages/embedded.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-13 17:18:24 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-13 17:48:25 +0100
commit8394619baceb118df92e355377fd543bb1aa501a (patch)
tree504f07c2a9f88596a305b59ef45f941062426a52 /gnu/packages/embedded.scm
parentaca2defe0172868295941fd9f0e97886f6e9b2d4 (diff)
downloadguix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar
guix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar.gz
gnu: Simplify package inputs.
This commit was obtained by running: ./pre-inst-env guix style without any additional argument.
Diffstat (limited to 'gnu/packages/embedded.scm')
-rw-r--r--gnu/packages/embedded.scm83
1 files changed, 31 insertions, 52 deletions
diff --git a/gnu/packages/embedded.scm b/gnu/packages/embedded.scm
index 4315cc0618..1c8b76c11d 100644
--- a/gnu/packages/embedded.scm
+++ b/gnu/packages/embedded.scm
@@ -295,9 +295,9 @@ usable on embedded products.")
(origin-patches (package-source gcc-7))
(search-patches "gcc-7-cross-environment-variables.patch")))))
(native-inputs
- `(("flex" ,flex)
- ("isl" ,isl-0.18)
- ,@(alist-delete "isl" (package-native-inputs xgcc))))
+ (modify-inputs (package-native-inputs xgcc)
+ (delete "isl")
+ (prepend flex isl-0.18)))
(arguments
(substitute-keyword-arguments (package-arguments xgcc)
((#:phases phases)
@@ -517,12 +517,9 @@ languages are C and C++.")
"0ndyfh51hiqyv2yscpj6qd091w7myxxjid3a6rx8f6k233vy826q"))))
(build-system gnu-build-system)
(native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("libtool" ,libtool)
- ("pkg-config" ,pkg-config)))
+ (list autoconf automake libtool pkg-config))
(inputs
- `(("libusb" ,libusb)))
+ (list libusb))
(home-page "https://repo.or.cz/w/libjaylink.git")
(synopsis "Library to interface Segger J-Link devices")
(description "libjaylink is a shared library written in C to access
@@ -560,7 +557,7 @@ SEGGER J-Link and compatible devices.")
)))
(native-inputs
;; For tests.
- `(("inetutils" ,inetutils))) ; for hostname
+ (list inetutils)) ; for hostname
(home-page "http://jim.tcl.tk/index.html")
(synopsis "Small footprint Tcl implementation")
(description "Jim is a small footprint implementation of the Tcl programming
@@ -585,18 +582,14 @@ language.")
"1q536cp80v2bcy6xwk08f1r2ljyw13jchx3a1z7d3ni3vqql7rc6"))))
(build-system gnu-build-system)
(native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("libtool" ,libtool)
- ("which" ,base:which)
- ("pkg-config" ,pkg-config)
- ("texinfo" ,texinfo)))
+ (list autoconf
+ automake
+ libtool
+ base:which
+ pkg-config
+ texinfo))
(inputs
- `(("hidapi" ,hidapi)
- ("jimtcl" ,jimtcl)
- ("libftdi" ,libftdi)
- ("libjaylink" ,libjaylink)
- ("libusb-compat" ,libusb-compat)))
+ (list hidapi jimtcl libftdi libjaylink libusb-compat))
(arguments
'(#:configure-flags
(append (list "LIBS=-lutil"
@@ -699,8 +692,8 @@ with a layered architecture of JTAG interface and TAP support.")
(origin-patches (package-source gcc-6))
(search-patches "gcc-cross-environment-variables.patch")))))
(native-inputs
- `(("flex" ,flex)
- ,@(package-native-inputs xgcc)))
+ (modify-inputs (package-native-inputs xgcc)
+ (prepend flex)))
;; All headers and cross libraries of the propeller toolchain are
;; installed under the "propeller-elf" prefix.
(native-search-paths
@@ -808,9 +801,7 @@ with a layered architecture of JTAG interface and TAP support.")
(lambda* (#:key make-flags #:allow-other-keys)
(apply invoke "make" "install-includes" make-flags))))))
(native-inputs
- `(("propeller-gcc" ,propeller-gcc)
- ("propeller-binutils" ,propeller-binutils)
- ("perl" ,perl)))
+ (list propeller-gcc propeller-binutils perl))
(home-page "https://github.com/parallaxinc/propgcc")
(synopsis "C library for the Parallax Propeller")
(description "This is a C library for the Parallax Propeller
@@ -902,8 +893,7 @@ code.")
(lambda _ (chdir "loader") #t))
(delete 'configure))))
(native-inputs
- `(("openspin" ,openspin)
- ("propeller-toolchain" ,propeller-toolchain)))
+ (list openspin propeller-toolchain))
(home-page "https://github.com/parallaxinc/propgcc")
(synopsis "Loader for Parallax Propeller micro-controllers")
(description "This package provides the tool @code{propeller-load} to
@@ -948,9 +938,7 @@ upload binaries to a Parallax Propeller micro-controller.")
'("testlex" "spin2cpp" "fastspin")))
#t)))))
(native-inputs
- `(("bison" ,bison)
- ("propeller-load" ,propeller-load)
- ("propeller-toolchain" ,propeller-toolchain)))
+ (list bison propeller-load propeller-toolchain))
(home-page "https://github.com/totalspectrum/spin2cpp")
(synopsis "Convert Spin code to C, C++, or PASM code")
(description "This is a set of tools for converting the Spin language for
@@ -1090,8 +1078,8 @@ the Raspberry Pi chip.")
(search-patches "gcc-6-fix-buffer-size.patch"
"gcc-6-fix-isl-includes.patch"))))
(native-inputs
- `(("flex" ,flex)
- ,@(package-native-inputs xgcc)))
+ (modify-inputs (package-native-inputs xgcc)
+ (prepend flex)))
(synopsis "GCC for VC4")
(description "This package provides @code{gcc} for VideoCore IV,
the Raspberry Pi chip."))))
@@ -1112,12 +1100,9 @@ the Raspberry Pi chip."))))
"1rypfb96k2szqgygp3jnwg2zq9kwmfz0460dsahn3r2vkzml8wn7"))))
(build-system gnu-build-system)
(inputs
- `(("libftdi" ,libftdi)
- ("python" ,python)))
+ (list libftdi python))
(native-inputs
- `(("pkg-config" ,pkg-config)
- ("swig" ,swig)
- ("which" ,base:which)))
+ (list pkg-config swig base:which))
(arguments
`(#:tests? #f ; No tests exist.
#:parallel-build? #f ; Would be buggy.
@@ -1257,7 +1242,7 @@ SPI, I2C, JTAG.")
#t))
(delete 'configure))))
(inputs
- `(("libx11" ,libx11)))
+ (list libx11))
(synopsis "Freecalypso host tools")
(description "This package provides some tools for debugging FreeCalypso phones and the FreeCalypso FCDEV3B dev board.
@@ -1370,12 +1355,10 @@ these identified regions.
"1d10qxyghz66zp7iqpm8q8rfv9jz9n609gxmfcav1lssmf1dlyk3"))))
(build-system python-build-system)
(propagated-inputs
- `(("python-pyserial" ,python-pyserial)
- ("python-pyusb" ,python-pyusb)
- ("python-tqdm" ,python-tqdm)))
+ (list python-pyserial python-pyusb python-tqdm))
(native-inputs
;; For tests.
- `(("python-pyyaml" ,python-pyyaml)))
+ (list python-pyyaml))
(home-page "https://github.com/grigorig/stcgal")
(synopsis "Programmer for STC 8051-compatible microcontrollers")
(description "stcgal is a command-line flash-programming tool for STC
@@ -1408,7 +1391,7 @@ STC89, STC90, STC10, STC11, STC12, STC15 and STC8 series.")
(list (string-append "-DSTLINK_UDEV_RULES_DIR=" udev-rules)
(string-append "-DSTLINK_MODPROBED_DIR=" modprobe)))))
(inputs
- `(("libusb" ,libusb)))
+ (list libusb))
(synopsis "Programmer for STM32 Discovery boards")
(description "This package provides a firmware programmer for the STM32
Discovery boards. It supports two versions of the chip: ST-LINK/V1 (on
@@ -1433,10 +1416,8 @@ raw USB commands.")
(base32
"0ql6ij1hrj2ir5wkxm96zgig5qwvfwa75w77wh2y13w6b9cqcr4b"))))
(propagated-inputs
- `(("python-colorama" ,python-colorama)
- ("python-configobj" ,python-configobj)
- ("python-pykwalify" ,python-pykwalify)
- ("python-pyyaml" ,python-pyyaml)))
+ (list python-colorama python-configobj python-pykwalify
+ python-pyyaml))
(build-system python-build-system)
(home-page "https://github.com/zephyrproject-rtos/west")
(synopsis "Zephyr RTOS Project meta-tool")
@@ -1476,7 +1457,7 @@ debugging them, and more.")
config-destination)
#t))))))
(inputs
- `(("mosquitto" ,mosquitto)))
+ (list mosquitto))
(native-inputs
`(("automake" ,automake)
("autoconf" ,autoconf)
@@ -1528,8 +1509,7 @@ handling communication with eBUS devices connected to a 2-wire bus system
(string-append (assoc-ref outputs "out") "/share/man"))
#t)))))
(native-inputs
- `(("bison" ,bison)
- ("flex" ,flex)))
+ (list bison flex))
(home-page "http://mazsola.iit.uni-miskolc.hu/ucsim/")
(synopsis "Simulators for various microcontroller families")
(description "μCsim is a collection of software simulators for
@@ -1619,8 +1599,7 @@ families, plus many of their variants.")
(("from IPython.*") ""))))))
(build-system python-build-system)
(propagated-inputs
- `(("python-cryptography" ,python-cryptography)
- ("python-prettytable" ,python-prettytable)))
+ (list python-cryptography python-prettytable))
(home-page "https://github.com/PSPReverse/psptool")
(synopsis "Tool for dealing with AMD binary blobs")
(description "PSPTool is a tool for dealing with AMD binary blobs")