summaryrefslogtreecommitdiff
path: root/gnu/packages/embedded.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-02-11 11:41:15 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-02-11 11:42:09 +0100
commit8226304b17624b33e3c9245cd3022f0e9b7fac26 (patch)
tree14508a2e78213a9197250b2b5e9e99139157b89c /gnu/packages/embedded.scm
parentaba3e482b9cc239b685f81fd718a3dc49545f1f8 (diff)
downloadguix-patches-8226304b17624b33e3c9245cd3022f0e9b7fac26.tar
guix-patches-8226304b17624b33e3c9245cd3022f0e9b7fac26.tar.gz
gnu: propeller-gcc: Fix build.
* gnu/packages/embedded.scm (propeller-gcc)[native-inputs]: Use GCC 4.9.
Diffstat (limited to 'gnu/packages/embedded.scm')
-rw-r--r--gnu/packages/embedded.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/embedded.scm b/gnu/packages/embedded.scm
index 870574ae18..b2e33ea10b 100644
--- a/gnu/packages/embedded.scm
+++ b/gnu/packages/embedded.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2016, 2017 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2016, 2017, 2018 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016, 2017 Theodoros Foradis <theodoros@foradis.org>
;;; Copyright © 2016 David Craven <david@craven.ch>
;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
@@ -525,6 +525,9 @@ with a layered architecture of JTAG interface and TAP support.")
`(modify-phases ,phases
(add-after 'unpack 'chdir
(lambda _ (chdir "gcc") #t))))))
+ (native-inputs
+ `(("gcc-4" ,gcc-4.9)
+ ,@(package-native-inputs propeller-gcc-6)))
(home-page "https://github.com/parallaxinc/propgcc")
(supported-systems (delete "aarch64-linux" %supported-systems)))))