summaryrefslogtreecommitdiff
path: root/gnu/packages/embedded.scm
diff options
context:
space:
mode:
authorClément Lassieur <clement@lassieur.org>2021-02-25 12:15:12 +0100
committerLéo Le Bouter <lle-bout@zaclys.net>2021-02-26 00:01:56 +0100
commit337cb4a0481ed08b672cc70d601d1b60f2edcebd (patch)
treeb3148019948cd11e95558429b4996cfc97511ff9 /gnu/packages/embedded.scm
parentcc628f255248777225b4fe4e4a011f6bb503632b (diff)
downloadguix-patches-337cb4a0481ed08b672cc70d601d1b60f2edcebd.tar
guix-patches-337cb4a0481ed08b672cc70d601d1b60f2edcebd.tar.gz
gnu: Add agent-proxy.
* gnu/packages/embedded.scm (agent-proxy): New variable. Signed-off-by: Léo Le Bouter <lle-bout@zaclys.net>
Diffstat (limited to 'gnu/packages/embedded.scm')
-rw-r--r--gnu/packages/embedded.scm39
1 files changed, 38 insertions, 1 deletions
diff --git a/gnu/packages/embedded.scm b/gnu/packages/embedded.scm
index 16e9e6be76..51ee244f3c 100644
--- a/gnu/packages/embedded.scm
+++ b/gnu/packages/embedded.scm
@@ -4,7 +4,7 @@
;;; Copyright © 2016 David Craven <david@craven.ch>
;;; Copyright © 2017, 2020 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
-;;; Copyright © 2018, 2019 Clément Lassieur <clement@lassieur.org>
+;;; Copyright © 2018, 2019, 2021 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2020 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
;;; Copyright © 2021 Julien Lepiller <julien@lepiller.eu>
@@ -1547,3 +1547,40 @@ families, plus many of their variants.")
(synopsis "Tool for dealing with AMD binary blobs")
(description "PSPTool is a tool for dealing with AMD binary blobs")
(license license:gpl3+)))
+
+(define-public agent-proxy
+ (let ((commit "8927798a71d246871ea8fc22b4512296a3fa1765")
+ (revision "0"))
+ (package
+ (name "agent-proxy")
+ (version (git-version "1.98" revision commit))
+ (home-page
+ "https://git.kernel.org/pub/scm/utils/kernel/kgdb/agent-proxy.git")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference (url home-page) (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1bxkzwsqfld4pknmiq8j3k55pv90n8s6kzh0xh42bhy2jv1wxz2z"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (add-after 'build 'build-kdmx
+ (lambda _
+ (invoke "make" "-C" "kdmx")
+ #t))
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((bin (string-append (assoc-ref outputs "out") "/bin")))
+ (install-file "agent-proxy" bin)
+ (install-file "kdmx/kdmx" bin)
+ #t))))))
+ (synopsis "Proxies to run kgdb/gdbserver and console on a serial port")
+ (description "These programs are proxies allowing to run kgdb/gdbserver
+and console on a single serial port. agent-proxy creates network sockets,
+whereas kdmx creates pseudo-ttys.")
+ (license license:gpl2))))