summaryrefslogtreecommitdiff
path: root/gnu/packages/embedded.scm
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2020-08-22 20:26:17 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2020-08-22 20:37:41 +0200
commit1bb4fd64b7bbe5a17eda6f0ca8105283c038f7c8 (patch)
treebe30fdf4c571bb0da382b5a684347a4421531657 /gnu/packages/embedded.scm
parentca7eada91819c7cd5a78e144d285cd972a478a0c (diff)
downloadguix-patches-1bb4fd64b7bbe5a17eda6f0ca8105283c038f7c8.tar
guix-patches-1bb4fd64b7bbe5a17eda6f0ca8105283c038f7c8.tar.gz
gnu: fc-host-tools: Update to 13.
* gnu/packages/embedded.scm (fc-host-tools): Update to 13. [description]: Modify.
Diffstat (limited to 'gnu/packages/embedded.scm')
-rw-r--r--gnu/packages/embedded.scm10
1 files changed, 8 insertions, 2 deletions
diff --git a/gnu/packages/embedded.scm b/gnu/packages/embedded.scm
index 558369f15d..31fd7b05ce 100644
--- a/gnu/packages/embedded.scm
+++ b/gnu/packages/embedded.scm
@@ -1161,14 +1161,14 @@ SPI, I2C, JTAG.")
(define-public fc-host-tools
(package
(name "fc-host-tools")
- (version "11")
+ (version "13")
(source (origin
(method url-fetch)
(uri (string-append "ftp://ftp.freecalypso.org/pub/GSM/"
"FreeCalypso/fc-host-tools-r" version ".tar.bz2"))
(sha256
(base32
- "0s87lp6gd8i8ivrdd7mnnalysr65035nambcm992rgla7sk76sj1"))))
+ "0bpxz4y0z3hmlirzvfwq0k45yzn9fzgqs9r1fpkrhn48gr2zrpa8"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; No tests exist.
@@ -1282,6 +1282,12 @@ and displaying decoded target responses.
@item fcup-smsendmult: Send multiple short messages via SMS in one go
@item fcup-smsendpdu: Send multiple short messages given in PDU format via SMS
@item sms-pdu-decode: Decode PDU format messages
+@item fc-dspromdump: Dump DSP ROM.
+@item pcm-sms-decode: Decode /pcm/SMS binary files read out of FFS maintained
+by Pirelli DP-L10. Display the SMS in human-readable form.
+@item srec-regions: Parse S-record (TI's *.m0), identify the set of
+discontiguous regions into which this SREC image deposits bits, and list
+these identified regions.
@end enumerate")
(home-page "https://www.freecalypso.org/")
(license license:public-domain)))