summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs.scm
diff options
context:
space:
mode:
authorLeo Prikler <leo.prikler@student.tugraz.at>2021-04-17 19:06:18 +0200
committerLeo Prikler <leo.prikler@student.tugraz.at>2021-05-01 15:56:37 +0200
commitd13b46fae46fe0e0d529e67ffc7f4074440d1b6e (patch)
tree2615fb3d22dd205021760d1be3055fb98997d3b0 /gnu/packages/emacs.scm
parent307a2d2e2a833c2e1f7a79f46e4c6945c618cd8c (diff)
downloadguix-patches-d13b46fae46fe0e0d529e67ffc7f4074440d1b6e.tar
guix-patches-d13b46fae46fe0e0d529e67ffc7f4074440d1b6e.tar.gz
gnu: emacs: Add coreutils and gzip to PATH.
Some parts of Emacs (dired, compression handling, Tramp) shell out to commands and patching them all is a daunting task. Also, w.r.t. Tramp, we need those commands to be portable across multiple machines, which need not only be Guix machines (and even if they are, store items can be different). This patch ensures a ‘sane’ setup FSVO ‘sane’. * gnu/packages/emacs.scm (emacs)[wrap-load-path]: Rename to... [wrap-emacs-paths] ... this. Also patch PATH.
Diffstat (limited to 'gnu/packages/emacs.scm')
-rw-r--r--gnu/packages/emacs.scm19
1 files changed, 16 insertions, 3 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index e1b01ac22b..5316d25151 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -201,8 +201,8 @@
(car (find-files "bin" "^emacs-([0-9]+\\.)+[0-9]+$"))
"bin/emacs")
#t)))
- (add-after 'strip-double-wrap 'wrap-load-path
- (lambda* (#:key outputs #:allow-other-keys)
+ (add-after 'strip-double-wrap 'wrap-emacs-paths
+ (lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
(lisp-dirs (find-files (string-append out "/share/emacs")
"^lisp$"
@@ -210,6 +210,13 @@
(for-each
(lambda (prog)
(wrap-program prog
+ ;; emacs-next and variants rely on uname being in PATH for
+ ;; Tramp. Tramp paths can't be hardcoded, because they
+ ;; need to be portable.
+ `("PATH" suffix
+ ,(map (lambda (in) (string-append in "/bin"))
+ (list (assoc-ref inputs "gzip")
+ (assoc-ref inputs "coreutils"))))
`("EMACSLOADPATH" suffix ,lisp-dirs)))
(find-files (string-append out "/bin")
;; Matches versioned and unversioned emacs binaries.
@@ -231,6 +238,10 @@
`(("gnutls" ,gnutls)
("ncurses" ,ncurses)
+ ;; Required for "core" functionality, such as dired and compression.
+ ("coreutils" ,coreutils)
+ ("gzip" ,gzip)
+
;; Avoid Emacs's limited movemail substitute that retrieves POP3 email
;; only via insecure channels. This is not needed for (modern) IMAP.
("mailutils" ,mailutils)
@@ -361,7 +372,9 @@ also enabled and works without glitches even on X server."))))
(delete 'strip-double-wrap)))))
(inputs
`(("guix-emacs.el" ,(search-auxiliary-file "emacs/guix-emacs.el"))
- ("ncurses" ,ncurses)))
+ ("ncurses" ,ncurses)
+ ("coreutils" ,coreutils)
+ ("gzip" ,gzip)))
(native-inputs
`(("pkg-config" ,pkg-config)))))